www.zeroshell.org Forum Index www.zeroshell.org
Linux Distribution for server and embedded devices
 
 SearchSearch  RegisterRegister  UsergroupsUsergroups 
 ProfileProfile  Log inLog in  Log in to check your private messagesPrivate Message 

ISP connection setup issue

 
Post new topic   Reply to topic    www.zeroshell.org Forum Index -> ZeroShell
View previous topic :: View next topic  
Author Message
xtacy



Joined: 28 Aug 2010
Posts: 20

PostPosted: Sat Apr 14, 2012 2:07 pm    Post subject: ISP connection setup issue Reply with quote

Hi!
I have very strange issue with my new secondary ISP (on ETH02) using ZS. Wanna say first that without ZS everything works fine with that ISP (directly connected to my PC).
Its a cable connection like from ISP's router/switch etc port to my PC by ehernet. ISP has DHCP so my PC obtains dynamic IP every time but that IP is the same each time (176.8.11.254).

When I connect the cable to ZS it obtains IP too but slightly different ( Dynamic IP: 176.8.10.151) which is ok due to other MAC (I also tried other PCs directly connected to that ISP and each time there was different IP but everything works fine).

Issue#1. 1st time ZS boots up it doesn't share the Internet (and it can't see it, Utils-ping fails). So I have to login to ZS and make ETH02 disconnect and connect (setup-Network, the "UP" checkbox of ETH02 clear and set). After that procedure ZS starts to share Internet and it does "see" it (ping in Utils menu goes fine). That's not a big deal, I could manually reactivate connection every time but I'm using ZS for it's Net Ballancing feature. And here is the problem.
Issue#2. I got NetBallancer configured (and it works just fine with my primary ISP which is PPPoE and was physically disconnected for setup and test purposes). I did add my secondary ISP via it's dynamic IP (176.8.10.151) cuz there is no PPPoE and my IP wont change anyway. And the problem is - NB reports that it fails (while ZS shares Internet and I have Internet on my PC connected to ZS). So I tried to make it just ETH02 instead of IP (in NB) but it fails either.

That means when my primary ISP will fail ZS wont do anything cuz it counts the second connection as failed anyway. Moreover ZS wont use secondary ISP at all.

So I can't figure out how to get rid of needing to reconnect ETH02 every time ZS boots (issue#1) and how to setup my secondary ISP connection properly to use it with NB (issue#2).

thanx
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    www.zeroshell.org Forum Index -> ZeroShell All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group