www.zeroshell.org Forum Index www.zeroshell.org
Linux Distribution for server and embedded devices
 
 SearchSearch  RegisterRegister  UsergroupsUsergroups 
 ProfileProfile  Log inLog in  Log in to check your private messagesPrivate Message 

Netbalancer changes route too often => web banking broken

 
Post new topic   Reply to topic    www.zeroshell.org Forum Index -> ZeroShell
View previous topic :: View next topic  
Author Message
mark_orion



Joined: 06 Mar 2009
Posts: 27

PostPosted: Wed Oct 21, 2009 12:46 pm    Post subject: Netbalancer changes route too often => web banking broken Reply with quote

We notice in our network that certain web services do not work properly since we enabled the Zeroshell load balancer. These sites do not allow the route to change during a web session. They are mostly online banking sites, but even posting to this forum is causing trouble: I am always asked to login again and again whenever the Netbalancer sends my HTTP requests through a different gateway.
Is there a way to create more "stickyness" in the net balancing system so that the route does not change at least within a reasonable amount of time (say 20 minutes)? Or is it possible to completely change the load balancing algorithm from session to IP based (host1 gets gateway1, host two gateway two, host three gets gateway1 again and so on)?
I would prefer a general solution for this problem rather than setting up manual balancing rules for every machine or banking server.
I am very grateful for any kind of help.
Back to top
View user's profile Send private message
ppalias



Joined: 17 Dec 2008
Posts: 1151
Location: Athens, Greece

PostPosted: Thu Oct 22, 2009 6:44 am    Post subject: Reply with quote

It has been reported again. For the time being adding a static route for the sites or a balancing rule for the internal IP addresses is the only way.
Back to top
View user's profile Send private message Yahoo Messenger MSN Messenger
omicron



Joined: 20 Jun 2012
Posts: 2

PostPosted: Wed Jun 20, 2012 5:01 pm    Post subject: The same... Reply with quote

Hi guys!

I can see the thread was opened in 2009...
Today, in 2012, there is no solution to resolve dinamically this issue using ZeroShell...

The "solution" to add the IP address statically is not a good way because my users are using a lot of sites who need to maintain web sessions, and there is complicated to maintain a very large list of IP addresses...

There is a real necessity to resolve this.

If you have any idea, it would be welcomed.

Thank you guys in advance!
Regards Smile
Back to top
View user's profile Send private message
redfive



Joined: 27 Aug 2009
Posts: 232

PostPosted: Wed Jun 20, 2012 7:19 pm    Post subject: Reply with quote

Hi orion , you could try with Atheling's patch , seems fix the issue...
http://www.zeroshell.net/eng/forum/viewtopic.php?t=3306&highlight=
ciao
Back to top
View user's profile Send private message
omicron



Joined: 20 Jun 2012
Posts: 2

PostPosted: Thu Jun 21, 2012 6:38 am    Post subject: Reply with quote

Thank you!
I will take a look Smile
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    www.zeroshell.org Forum Index -> ZeroShell All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group