www.zeroshell.org Forum Index www.zeroshell.org
Linux Distribution for server and embedded devices
 
 SearchSearch  RegisterRegister  UsergroupsUsergroups 
 ProfileProfile  Log inLog in  Log in to check your private messagesPrivate Message 

Zeroshell CaptivePortal not working

 
Post new topic   Reply to topic    www.zeroshell.org Forum Index -> ZeroShell
View previous topic :: View next topic  
Author Message
ovidiu



Joined: 30 Mar 2013
Posts: 2

PostPosted: Sun Mar 31, 2013 7:14 am    Post subject: Zeroshell CaptivePortal not working Reply with quote

Hi,

I'm trying to use this great product for creating a Captive Portal in a small public place. Because i don't have a public IP addres, i decided to use ZS in BridgeMode. My setup is like this:

ISP---> Gateway (192.168.1.100) <---> (ETH00) ZeroShell Bridge (ETH01) <---> WiFi or LAN

Unfortunately this setup is not working when CaptivePortal is Enabled (tried to activate on Bridge & LAN). DHCP also is not working, not getting any ip addres nor with CaptivePortal de-activated.Everything seems to be fine with CaptivePortal OFF and manual IP address. When i try a ping toward GW, i'm getting a Destination Port Unreachable form interface ETH00 wich is the interface of ZS toward GW.

Thank you
Back to top
View user's profile Send private message
ik.omoruyi



Joined: 19 May 2013
Posts: 8

PostPosted: Sun May 19, 2013 7:30 pm    Post subject: Reply with quote

There are solutions out there for this.
Here is my solution:

Login as admin

goto Router --> NAT

On the NAT popup page, move ETH00 and ETH01 from Available Interfaces to NAT Enabled Interfaces, then save it and close it.

goto DHCP and click on the New button and create a network on the New DHCP Subnet definition window that pops up(select ETH01).
After creating the network, with the network now showing in the subnet, In the Dynamic IP Configuration section, select the IP range you want, click save in the main DHCP window, Active on: NONE should change to Active on: ETH01.

goto Captive Portal, on the Interface dropdown menu, select ETH01, enable the Active on: checkbox and save. After saving the status should become Active on: ETH01.

Now anybody connected to ETH01 port should get a dhcp address from what you specified earlier on and when trying to do anything will prompted with a login screen. Hopefully, you've set up users already.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    www.zeroshell.org Forum Index -> ZeroShell All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group