www.zeroshell.org Forum Index www.zeroshell.org
Linux Distribution for server and embedded devices
 
 SearchSearch  RegisterRegister  UsergroupsUsergroups 
 ProfileProfile  Log inLog in  Log in to check your private messagesPrivate Message 

automated disconnect

 
Post new topic   Reply to topic    www.zeroshell.org Forum Index -> ZeroShell
View previous topic :: View next topic  
Author Message
woodym



Joined: 28 Dec 2008
Posts: 4

PostPosted: Mon Dec 29, 2008 2:58 am    Post subject: automated disconnect Reply with quote

hello,

my next question Wink

how can i disconnect a running pppoe-connection with cron.

in germany the dsl-provider disconnect every 24 hours. if i disconnect at a given time i can controll the 24-hour-cycle.

which command must i set to the cron to disconnect a pppoe-connection?

bye woodym
Back to top
View user's profile Send private message
fulvio
Site Admin


Joined: 01 Nov 2006
Posts: 1068

PostPosted: Mon Dec 29, 2008 9:46 am    Post subject: Reply with quote

killall pppd

should killl all point to point connections.

Regards
Fulvio
Back to top
View user's profile Send private message Send e-mail
Matze



Joined: 02 Aug 2012
Posts: 4

PostPosted: Mon Feb 02, 2015 2:18 pm    Post subject: reconnect not working with ZS 3.3.x Reply with quote

Hi,

the cron with "killall pppd" works nice in all ZS versions but isn't work in 3.3.x
The reconnect works, but the net balancer not notice this the connection was rebuilt = the connection remains on the status failed.
(In Germany kill the most ISP's the connection after 24 hours)

I have in NetBalancer for this connection remove the hook "UP" and sit down again, then it works again and the connection is set to active.

In the logs I find no clue why the NetBalancer the connection no longer recognizes:

starting the killall pppd cron:
pppd:
14:52:20 Terminating on signal 15
14:52:20 Connect time 364.7 minutes.
14:52:20 Sent 210239120 bytes, received 2857866466 bytes.
14:52:20 Connection terminated.
14:52:20 Exit.
14:52:25 pppd 2.4.3 started by root, uid 0
14:52:25 Using interface ppp0
14:52:25 Connect: ppp0 <--> /dev/pts/0
14:52:27 PAP authentication succeeded
14:52:27 local IP address [clean_IP]
14:52:27 remote IP address [clean_IP]

pppoe-connect:
14:52:20 PPPoE connection lost; attempting re-connection.

NetBalancer:
14:52:28 [ICMP] No link detected with the gateway (VDSL)
14:52:28 [ICMP] FAULT: VDSL (Interface: ppp0) [Last Uptime: 6h 4m 17s]
14:52:28 Default Route has been changed: nexthop via 192.168.4.1 weight 1 realm 100
14:53:44 (TEST) ==============================================================
14:53:44 (TEST) GATEWAY : DEFAULT GATEWAY (192.168.4.1)
14:53:44 (TEST) => [173.194.112.175] : Success (Round Trip Time: 63.0 ms)
14:53:44 (TEST) => [193.99.144.85] : Success (Round Trip Time: 59.2 ms)
14:53:44 (TEST) => [212.227.222.9] : Success (Round Trip Time: 62.3 ms)
14:53:44 (TEST) GATEWAY : VDSL (ppp0)
14:53:47 (TEST) => [173.194.112.175] : ERROR
14:53:50 (TEST) => [193.99.144.85] : ERROR
14:53:53 (TEST) => [212.227.222.9] : ERROR
14:53:53 (TEST) ==============================================================
14:53:53 [ICMP] Failover monitor has started
14:54:29 [ICMP] Failover monitor has started
14:54:31 Default Route has been changed: nexthop dev ppp0 weight 2 realm 101
14:54:33 [ICMP] Failover monitor has started
Back to top
View user's profile Send private message
Matze



Joined: 02 Aug 2012
Posts: 4

PostPosted: Tue Feb 03, 2015 2:38 pm    Post subject: Reply with quote

Edit: I take it all back... the netbalancer don't work correctly in zs 3.3.2 with ppp connections. After the kill cron in the night, the netbalancer take the connection to the state "standby" (wight is upper = no standby for this connection). When disable the second connection (backup) go the state from standby to fault! (ppp connect is up! only the netbalancer report error for this connection to any test ip (TEST) => [173.194.112.175] : ERROR)

I disable the netbalancer in my productive environment as workaround.

Old Message:
I think i found the configuration solution:

old ZS Release 3.2.x and older working the netbalancer perfect with the option in the ppp0 configure:

Autostart the connection: "Yes"

In the newer Releas 3.3.x working the netbalancer after a disconnect only with this option in the ppp0 configure:

Autostart the connection: "On Net Balancer Fault"

In the configure page i see the note:
Note: Autostart the connection [On Net Balancer Fault] works if the PPPoE interface belongs to the Gateway Pool configured in the Net Balancer.
Back to top
View user's profile Send private message
gastone



Joined: 17 Dec 2014
Posts: 3

PostPosted: Fri Feb 06, 2015 8:33 pm    Post subject: Same behaviour Reply with quote

I confirm...

I have the same identical behaviour... Sad
Back to top
View user's profile Send private message
erick06fr



Joined: 04 Feb 2015
Posts: 5

PostPosted: Mon Feb 09, 2015 1:41 pm    Post subject: Reply with quote

Same problem in ZS 3.3.2. Unable to bring-up PPOE after failure in net balancer without a manual de-activation / re-recativation of the net-balancer PPOE member entry.
Needs also a manuel clean of the Gateway Alarm entry
As far as I can remenber it was OK on ZS 3.3.1
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    www.zeroshell.org Forum Index -> ZeroShell All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group