www.zeroshell.org Forum Index www.zeroshell.org
Linux Distribution for server and embedded devices
 
 SearchSearch  RegisterRegister  UsergroupsUsergroups 
 ProfileProfile  Log inLog in  Log in to check your private messagesPrivate Message 

Strange behaviour after Auto Updadate of Bugfix 23320

 
Post new topic   Reply to topic    www.zeroshell.org Forum Index -> ZeroShell
View previous topic :: View next topic  
Author Message
getout



Joined: 15 Apr 2014
Posts: 26

PostPosted: Wed Jul 15, 2015 2:41 am    Post subject: Strange behaviour after Auto Updadate of Bugfix 23320 Reply with quote

I noticed a "Requires Reboot" in red in ZS home homepage. Logs show that there was an automatic update applied this morning for Bugfix 23320 (a VPN fail-over bugfix). Once rebooted there was no connectivity with ZS again. There seemed to be some routing going on but it was very broken. From terminal I rebooted again, still the same result. From the terminal I stopped iptables and tried the web GUI again but there was still no connectivity with ZS (even in layer 2). I rebooted a third time with iptables stopped and everything seemed to come back online. However, I noticed that the previously installed Bugfix 23320 was not not in the installed list but in the Available list. I noticed that my subscription had expired in May 2015.

Could the expired subscription have caused this glitch to occur on reboot?

Cheers.
Back to top
View user's profile Send private message
von_Schlieffen



Joined: 28 May 2013
Posts: 50

PostPosted: Wed Jul 15, 2015 7:08 am    Post subject: Reply with quote

same problem, need to reboot twice to get Zeroshell working again.

But package "23321 BUG FIX #01 - Net Balancer and VPN Failover" didn't display as installed. If I try to install package "23320 BUG FIX #00 - Net Balancer and VPN Failover", program display an error message that explain 23321 is installed.

Kind regards.
Back to top
View user's profile Send private message
getout



Joined: 15 Apr 2014
Posts: 26

PostPosted: Wed Jul 15, 2015 8:50 am    Post subject: Reply with quote

Turns out there's a problem with the 23321 update. Fulvio is working on a solution now. You will find Netbalancer will have issues until Fulvio provides a fix. It helped to reduce problems by removing QOS from some of the gateways listed in Netbalancer. Lets hope we get a fix soon.
Back to top
View user's profile Send private message
Lightyear



Joined: 24 Dec 2009
Posts: 14
Location: Montevideo, Uruguay

PostPosted: Fri Jul 17, 2015 3:32 am    Post subject: Reply with quote

In the meanwhile you can ssh to zeroshell and go to the shell prompt (option S)
Then: cd /var/register/system/AutoUpdate/pkgs/
There it should be directory 23321 with the troublesome patch. Rename it to anything lesser than 23320:

mv 23321 23319

Sadly I don't remember if I erased 23320; I believe I didn't, but if necessary, you could do

rm -rdf 23320

Then exit the shell prompt and log in via the web interface. Now you can happily reinstall 23320.

Just in case 23321 tries to make a comeback, let's make a file with the same name.
Go back to the shell prompt and cd /var/register/system/AutoUpdate/pkgs/
Then,

touch 23321

And, to be on the safe side, make it unwritable at least as long as it is not chmodded:

chmod 444 23321

Of course, instead of renaming you could erase 23321. I believe it should work, but I really don't know.

Hope this helps, it worked for me.
Back to top
View user's profile Send private message
getout



Joined: 15 Apr 2014
Posts: 26

PostPosted: Fri Jul 17, 2015 6:29 am    Post subject: Reply with quote

Thanks Lightyear. Hopefully Fulvio will sort out the 23321 update soon.

Do you know anyway to turn off Automatic updates via cmd? I think this is necessary for critical instances of ZS.

Cheers.

Edit: After applying the 23321 I do remember seeing during reboot "23321 modified scripts Success". Maybe re-applying the 23320 will modify the same scripts again back to what they were.....maybe not.

Just in case will definitely snapshot ZS VM before modifying this time!
Back to top
View user's profile Send private message
Lightyear



Joined: 24 Dec 2009
Posts: 14
Location: Montevideo, Uruguay

PostPosted: Fri Jul 17, 2015 11:28 am    Post subject: Reply with quote

Normally, I am very respectful of code I don't quite understand. In this case, I was forced to investigate because for me Zeroshell is mission-critical and I could not wait for a patch.

So, you have been warned, continue reading at your own risk Neutral

Perhaps the best bet would be to add

chmod 644 /root/kerbynet.cgi/scripts/autoupdater

to the pre boot script.
Of course, this would stop all autoupdates, but I really can't say what unwanted effects it would also bring.
In any case, better try it with a disposable backup Wink
Back to top
View user's profile Send private message
getout



Joined: 15 Apr 2014
Posts: 26

PostPosted: Thu Jul 23, 2015 9:12 pm    Post subject: Reply with quote

I have noticed some of my other ZS instances received the Bug Fix 23321 Autoupdate only yesterday. Anyone know if this is the same problematic update or is this one supposed to be fixed?.....

Fulvio....?
Back to top
View user's profile Send private message
getout



Joined: 15 Apr 2014
Posts: 26

PostPosted: Fri Jul 24, 2015 10:15 pm    Post subject: Reply with quote

After trying the new re-update of 23321 it seems that the BugFix is now operating correctly. Thanks for fixing that up Fulvio.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    www.zeroshell.org Forum Index -> ZeroShell All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group