www.zeroshell.org Forum Index www.zeroshell.org
Linux Distribution for server and embedded devices
 
 SearchSearch  RegisterRegister  UsergroupsUsergroups 
 ProfileProfile  Log inLog in  Log in to check your private messagesPrivate Message 

https port not change after boot

 
Post new topic   Reply to topic    www.zeroshell.org Forum Index -> Signal a BUG
View previous topic :: View next topic  
Author Message
kirck



Joined: 10 Jan 2013
Posts: 1

PostPosted: Thu Jan 10, 2013 3:45 pm    Post subject: https port not change after boot Reply with quote

Hello,

I want to change my https port to access to zeroshell. When I edit the https port and click save, the old https port value load again. Then I reboot the zeroshell but the port access don't change it, and I have to access with the old port value.

My Release is 1.0.beta16

Sorry for my bad english, and thanks in advance.
Back to top
View user's profile Send private message
pgbuz



Joined: 05 Aug 2016
Posts: 38

PostPosted: Tue Sep 06, 2016 7:18 pm    Post subject: Reply with quote

confirm the problem. This happen when I try to change https port from https web page management connection. Cannot use http connection.
Kernel 4.4.13-ZS
Release 3.6.0
Back to top
View user's profile Send private message
iulyb



Joined: 02 Jun 2016
Posts: 105

PostPosted: Fri Sep 09, 2016 2:02 am    Post subject: Reply with quote

Hi,
I just did a few unit tests and I can confirm your bug.
I created a new branch for bugs https://github.com/jb68/zeroshell-ui/tree/bugfix
and uploaded a 2 lines change fix for this.

You can create a patch and apply it to sethttps script
https://github.com/jb68/zeroshell-ui/commit/b318da683954cc563d24dd270bd7dc4951dd88e0

You can also change every time both http and https port and should work.
Back to top
View user's profile Send private message
pgbuz



Joined: 05 Aug 2016
Posts: 38

PostPosted: Tue Sep 13, 2016 5:48 am    Post subject: Reply with quote

[quote="iulyb"]Hi,
a 2 lines change fix for this.
quote]

I added the two lines at the file /root/kerbynet.cgi/scripts/sethttps and the correction is deleted after reboot. So I couldn't use it.

Can you help me about the patch making? I have to use the cron script editor? how? Thank you
Back to top
View user's profile Send private message
iulyb



Joined: 02 Jun 2016
Posts: 105

PostPosted: Thu Sep 15, 2016 4:39 am    Post subject: Reply with quote

I have to admin a patch is not that simple so I did it for you.
If you are interested you can check http://tamsler.blogspot.ca/2009/02/patching-with-git-diff.html

I created the patch and uploaded it so all you need is to save it on a directory that is not rewrite on reboot and apply it every time.

Login to zs then
Code:

mkdir -p /DB/opt/patch && cd /DB/opt/patch
wget http://jb68.com/pkg/sethttps_ui-ZS-3.6.0.patch


Now on ZS web interface on preboot script add
Code:

cd /root/kerbynet.cgi &&  patch -p0 </DB/opt/patch/sethttps_ui-ZS-3.6.0.patch
Back to top
View user's profile Send private message
pgbuz



Joined: 05 Aug 2016
Posts: 38

PostPosted: Thu Sep 15, 2016 5:25 am    Post subject: bug http and https ports change Reply with quote

IulyB, you made a very easy way to solve. Solved for https port.
I cannot entry with 8080 default http port. I didn't understood yet if is a browser problem. Some people can confirm functionality of http port?
Thank you very much and Best regards
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    www.zeroshell.org Forum Index -> Signal a BUG All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group