www.zeroshell.org Forum Index www.zeroshell.org
Linux Distribution for server and embedded devices
 
 SearchSearch  RegisterRegister  UsergroupsUsergroups 
 ProfileProfile  Log inLog in  Log in to check your private messagesPrivate Message 

system freezing completely

 
Post new topic   Reply to topic    www.zeroshell.org Forum Index -> Signal a BUG
View previous topic :: View next topic  
Author Message
mailsvb



Joined: 03 Jul 2009
Posts: 5

PostPosted: Sat Dec 05, 2009 11:07 pm    Post subject: system freezing completely Reply with quote

Hi,

I have a problem with my zeroshell router. Sometimes the system seems to crash and it is totally frozen (you can't do anything)
My Hardware:
- ALIX 2D3 Board
- miniPCI Wlan Chip (WLM54GP23) Atheros chip: AR2413

Software / features i use:
- zeroshell Beta12
- Asterisk
- DHCP / DNS / PPPoE connection / 1 VPN to another zeroshell box
- WLAN AP is configured

The problem is very sporadic, sometimes the system is running for serveral days without a problem, sometimes it freezes twice a day.
(The other zeroshell box mentioned above is an older WRAP board without Asterisk and without WLAN --> this box is stable!)

I would like to send you (Fulvio) some log files, but everytime I hard restart the system after a crash (soft reboot is not possible) there seems to be no message in the logs from the time the system crashed.
Is there a way to activate some kind of deeper log level.

I have a syslog server available that could collect everything, since the space on the router is limited.

Thanks,
mailsvb
Back to top
View user's profile Send private message
luigi42



Joined: 17 Apr 2009
Posts: 3

PostPosted: Fri Jan 15, 2010 11:27 pm    Post subject: Reply with quote

I've seen this as well on different hardware (IP130). Any ideas on how to determine what is causing the hang? thanks
Back to top
View user's profile Send private message
azzido



Joined: 01 Jun 2008
Posts: 4

PostPosted: Sat Jan 16, 2010 4:54 pm    Post subject: Reply with quote

Same issue here. System freezes and has to be reset before I can connect to it again.

My Config:

ALIX.2C3
Wistron NeWeb CM9-GP with Atheros AR5004 chip
WiFi with WPA Enterprise + RADIUS
DHCP server (on 3 subnets)
DNS server
no VPN
no QoS

There are about 5 Wifi clients and 2 hardwired clients.

I would also like to know what's the best way to start trouble shooting this because I am not seeing anything useful in the logs.

TIA
Back to top
View user's profile Send private message
azzido



Joined: 01 Jun 2008
Posts: 4

PostPosted: Wed Jan 20, 2010 6:49 am    Post subject: Reply with quote

Well, my system went down today and would not boot again. I don't have access to my Alix board via null modem so I am not sure what it was displaying there, but I did not see anything in log files (i connected cf to desktop pc to check it).

My solution was to load clean ZeroShell install to a new cf and manually configure everything again. (painful process Sad ) I tried to transfer old profile to the new cf, but that did not work either, so I am pretty positive that there was something wrong with the old profile. I hope that now at least it will be stable again.
Back to top
View user's profile Send private message
azzido



Joined: 01 Jun 2008
Posts: 4

PostPosted: Tue Feb 09, 2010 5:04 am    Post subject: Reply with quote

So the system still crashes even with the new profile and when it does so there is nothing in the log files whatsoever. This is becoming really frustrating and it seems like the only option is to go look for an alternative router distribution Sad
Back to top
View user's profile Send private message
mailsvb



Joined: 03 Jul 2009
Posts: 5

PostPosted: Mon May 03, 2010 12:10 pm    Post subject: Reply with quote

I have already switched to an alternative router OS (openwrt).
I believe the whole problem is related to the madwifi drivers...

I am still a big fan of zeroshell and using it on other systems that do not have a wireless card installed!

Is anybody aware of how to update the madwifi drivers in zeroshell?? maybe this fixes the issue.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    www.zeroshell.org Forum Index -> Signal a BUG All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group