www.zeroshell.org Forum Index www.zeroshell.org
Linux Distribution for server and embedded devices
 
 SearchSearch  RegisterRegister  UsergroupsUsergroups 
 ProfileProfile  Log inLog in  Log in to check your private messagesPrivate Message 

Speed of Bonded VPN

 
Post new topic   Reply to topic    www.zeroshell.org Forum Index -> VPN
View previous topic :: View next topic  
Author Message
fenster



Joined: 24 May 2011
Posts: 4

PostPosted: Tue May 24, 2011 11:37 am    Post subject: Speed of Bonded VPN Reply with quote

Hello,

Sorry if this has already been answered, but any advice would be much appreciated, as I cant find a solution.

I have put a zeroshell box in our data centre with a 1gb uplink to the internet. I have a LAN interface and I have 3 WAN IP addresses on another NIC. This is site A.

At site B, I have three ADSLs, all roughly 2.3mb down and 600k up. I have put a zeroshell box on site here and connected the ADSL routers, all pass a routable public address to separate WAN NIC's. There is a seperate Lan interface here as well.

I created static routes on the site b box to make sure that each of the three WAN interfaces here connects to each of the three WAN interfaces on my datacentre machine, utilising an ADSL for each VPN.

I verified that the static routes were sending data over the correct ADSL's by doing traceroutes to my three datacentre IPs - all good.
NOTE : I have not enabled the netbalancer, as the static routes are sending the VPNs out over the right interfaces i.e

Site B Site A

WAN1 ADSL 1.1.1.1 ---Static route to datacentre ---WAN1 1.1.1.1
WAN2 ADSL 2.2.2.2 ---Static route to datacentre ---WAN2 2.2.2.2
WAN3 ADSL 3.3.3.3 ---Static route to datacentre ---WAN3 3.3.3.3

This routing works fine and I have created and tested three VPNs - one from each card to the three IPs in the datacentre. I tested the VPNs individually and then I added these to a bond without any trouble and added the routes to send data over the bond - straight forward so far.

I then tested throughput accross the bonded VPN to an FTP server on the LAN behind the ZS box in the datacentre. I only get just over 2.6mb down and 0.4mb upstream. The combined bandwidth of the three DSLs should be a lot higher this, as this only a bit more that the speed of one of them on its own. I have tried disconnecting one and then two of the ADSLs and I can see that there is definately a speed difference, so I know it is bonding but I just feel that something is maybe missing in the config to enable me to get the most out of the DSL bandwidth available.

I also created a bridge with the bond interfaces and the LAN interfaces at each end. This also works fine, but the speed issue is still the same.

I have tried settings on the QoS for the bond interface at btoh ends (setting the max and available to the total accross the ADSL connections combined) but this makes little difference.

I have been through the forums and I cant find an answer. I did read that weighting the connections might be a solution but in my case they are all very similar speeds anyway, so I don't this this matters.

Can someone please let me know where I have gone wrong?

Incidentally, I have no encryption enabled on the VPNs. I have tried compression but this makes it worse. The VPNs are UDP.

Please help!
Back to top
View user's profile Send private message
fenster



Joined: 24 May 2011
Posts: 4

PostPosted: Fri May 27, 2011 3:06 pm    Post subject: solved Reply with quote

I noticed that the system load was around 17% when I was downloading which was way to high given the spec of the machine.

Because I had been changing lots of settings when trying to get the box setup in the first place I figured I could have something set incorrectly.

I thought it would be easier to just start again on the client machine. I got a new install configured in about 20 minutes and this one has been totally fine, I'm impressed with the link aggregation, seems to work fine now.

Incidentally, I have not enabled the net balancer, just make sure you use static routes to send your VPNs out over each individual internet connection you have connected.

John
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    www.zeroshell.org Forum Index -> VPN All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group