www.zeroshell.org Forum Index www.zeroshell.org
Linux Distribution for server and embedded devices
 
 SearchSearch  RegisterRegister  UsergroupsUsergroups 
 ProfileProfile  Log inLog in  Log in to check your private messagesPrivate Message 

Load Balancing - need help restoring settings after HDD fail

 
Post new topic   Reply to topic    www.zeroshell.org Forum Index -> ZeroShell
View previous topic :: View next topic  
Author Message
DrmCa



Joined: 12 Apr 2011
Posts: 199

PostPosted: Sat Dec 14, 2013 3:59 am    Post subject: Load Balancing - need help restoring settings after HDD fail Reply with quote

Hi all,

Zeroshell served me well for a long time. Unfortunately one day router's HDD crashed and the profile and backups were destroyed. I had to re-create the setup by memory and some notes I've been taking. Almost everything now works exactly the same as before, except that for the life of me I cannot get it to load-balance!

The routing and l/b is set up via GUI as follows:

Code:
root@router root> ip rule list
0:      from all lookup local
32743:  from all fwmark 0x66 lookup 102
32744:  from all fwmark 0x65 lookup 101
32747:  from all fwmark 0xca lookup 202
32748:  from all fwmark 0xc9 lookup 201
32766:  from all lookup main
32767:  from all lookup default
root@router root> ip route list table 102
204.19.206.33 dev ppp0  proto kernel  scope link  src xxx.yyy.65.24
192.168.250.0/24 dev VPN99  proto kernel  scope link  src 192.168.250.254
10.10.10.0/24 dev ETH00  proto kernel  scope link  src 10.10.10.1
default dev ppp1  scope link
unreachable default  metric 99
root@router root> ip route list table 101
204.19.206.33 dev ppp0  proto kernel  scope link  src xxx.yyy.65.24
192.168.250.0/24 dev VPN99  proto kernel  scope link  src 192.168.250.254
10.10.10.0/24 dev ETH00  proto kernel  scope link  src 10.10.10.1
default dev ppp0  scope link
unreachable default  metric 99
root@router root> ip route list table 202
default dev ppp1
root@router root> ip route list table 201
default dev ppp0
root@router root> ip route list table main
204.19.206.33 dev ppp0  proto kernel  scope link  src xxx.yyy.65.24
204.19.206.33 dev ppp1  proto kernel  scope link  src xxx.yyy.65.28
192.168.250.0/24 dev VPN99  proto kernel  scope link  src 192.168.250.254
10.10.10.0/24 dev ETH00  proto kernel  scope link  src 10.10.10.1
default
        nexthop dev ppp0 weight 1
        nexthop dev ppp1 weight 1
root@router root> ip route list table local
local xxx.yyy.65.24 dev ppp0  proto kernel  scope host  src xxx.yyy.65.24
local 192.168.142.142 dev dummy1  proto kernel  scope host  src 192.168.142.142
broadcast 127.255.255.255 dev lo  proto kernel  scope link  src 127.0.0.1
local 10.10.10.1 dev ETH00  proto kernel  scope host  src 10.10.10.1
broadcast 192.168.142.255 dev dummy1  proto kernel  scope link  src 192.168.142.142
broadcast 10.10.10.0 dev ETH00  proto kernel  scope link  src 10.10.10.1
local xxx.yyy.65.28 dev ppp1  proto kernel  scope host  src xxx.yyy.65.28
broadcast 192.168.250.0 dev VPN99  proto kernel  scope link  src 192.168.250.254
local 192.168.141.142 dev dummy0  proto kernel  scope host  src 192.168.141.142
broadcast 10.10.10.255 dev ETH00  proto kernel  scope link  src 10.10.10.1
broadcast 192.168.250.255 dev VPN99  proto kernel  scope link  src 192.168.250.254
broadcast 127.0.0.0 dev lo  proto kernel  scope link  src 127.0.0.1
local 192.168.250.254 dev VPN99  proto kernel  scope host  src 192.168.250.254
local 127.0.0.1 dev lo  proto kernel  scope host  src 127.0.0.1
local 127.0.0.0/8 dev lo  proto kernel  scope host  src 127.0.0.1


Correct me if I am wrong - the below log shows that default route is always ppp0 and thus connections only get established over that one.

Code:
02:13:38    Default Route has been changed: nexthop dev ppp0 weight 1 realm 101
02:13:39    No link detected with the gateway (AEI_pppoe_2)
02:13:39    FAULT: AEI_pppoe_2 (Interface: ppp1) [Last Uptime: 3h 3m 17s]
02:13:56    Pings to 206.123.6.230 succeeded (5/5 required, 5/5 achieved) on gateway (AEI_pppoe_2)
02:13:56    RECOVERED: AEI_pppoe_2 (Interface: ppp1) [Last Downtime: 17s]
02:13:56    Default Route has been changed: nexthop dev ppp0 weight 1 realm 101 nexthop dev ppp1 weight 1 realm 102
16:08:17    Default Route has been changed: nexthop dev ppp0 weight 1 realm 101
16:08:18    No link detected with the gateway (AEI_pppoe_2)
16:08:18    FAULT: AEI_pppoe_2 (Interface: ppp1) [Last Uptime: 13h 54m 22s]
16:08:44    Pings to 206.123.6.230 succeeded (5/5 required, 5/5 achieved) on gateway (AEI_pppoe_2)
16:08:44    RECOVERED: AEI_pppoe_2 (Interface: ppp1) [Last Downtime: 26s]
16:08:44    Default Route has been changed: nexthop dev ppp0 weight 1 realm 101 nexthop dev ppp1 weight 1 realm 102
17:34:24    Default Route has been changed: nexthop dev ppp0 weight 1 realm 101
17:34:25    No link detected with the gateway (AEI_pppoe_2)
17:34:25    FAULT: AEI_pppoe_2 (Interface: ppp1) [Last Uptime: 1h 25m 41s]
17:34:55    Pings to 206.123.6.230 succeeded (5/5 required, 5/5 achieved) on gateway (AEI_pppoe_2)
17:34:55    RECOVERED: AEI_pppoe_2 (Interface: ppp1) [Last Downtime: 30s]
17:34:55    Default Route has been changed: nexthop dev ppp0 weight 1 realm 101 nexthop dev ppp1 weight 1 realm 102
18:34:11    Default Route has been changed: nexthop dev ppp0 weight 1 realm 101
18:34:16    No link detected with the gateway (AEI_pppoe_2)
18:34:16    FAULT: AEI_pppoe_2 (Interface: ppp1) [Last Uptime: 59m 21s]
18:35:10    Pings to 206.123.6.230 succeeded (5/5 required, 5/5 achieved) on gateway (AEI_pppoe_2)
18:35:10    RECOVERED: AEI_pppoe_2 (Interface: ppp1) [Last Downtime: 54s]
18:35:10    Default Route has been changed: nexthop dev ppp0 weight 1 realm 101 nexthop dev ppp1 weight 1 realm 102
18:52:37    Default Route has been changed: nexthop dev ppp0 weight 1 realm 101
18:52:40    No link detected with the gateway (AEI_pppoe_2)
18:52:40    FAULT: AEI_pppoe_2 (Interface: ppp1) [Last Uptime: 17m 30s]
18:52:53    Pings to 206.123.6.230 succeeded (5/5 required, 5/5 achieved) on gateway (AEI_pppoe_2)
18:52:53    RECOVERED: AEI_pppoe_2 (Interface: ppp1) [Last Downtime: 13s]
18:52:53    Default Route has been changed: nexthop dev ppp0 weight 1 realm 101 nexthop dev ppp1 weight 1 realm 102
20:13:09    Default Route has been changed: nexthop dev ppp0 weight 1 realm 101
20:13:14    No link detected with the gateway (AEI_pppoe_2)
20:13:14    FAULT: AEI_pppoe_2 (Interface: ppp1) [Last Uptime: 1h 20m 21s]
20:13:48    Pings to 206.123.6.230 succeeded (5/5 required, 5/5 achieved) on gateway (AEI_pppoe_2)
20:13:48    RECOVERED: AEI_pppoe_2 (Interface: ppp1) [Last Downtime: 34s]
20:13:48    Default Route has been changed: nexthop dev ppp0 weight 1 realm 101 nexthop dev ppp1 weight 1 realm 102
21:40:47    Default Route has been changed: nexthop dev ppp0 weight 1 realm 101
21:40:48    No link detected with the gateway (AEI_pppoe_2)
21:40:48    FAULT: AEI_pppoe_2 (Interface: ppp1) [Last Uptime: 1h 27m ]
21:41:22    Pings to 206.123.6.230 succeeded (5/5 required, 5/5 achieved) on gateway (AEI_pppoe_2)
21:41:22    RECOVERED: AEI_pppoe_2 (Interface: ppp1) [Last Downtime: 34s]
21:41:22    Default Route has been changed: nexthop dev ppp0 weight 1 realm 101 nexthop dev ppp1 weight 1 realm 102
22:05:15    Default Route has been changed: nexthop dev ppp0 weight 98 realm 101 nexthop dev ppp1 weight 1 realm 102
22:05:16    message repeated 3 times
22:05:17    Failover monitor has started
22:05:26    Default Route has been changed: nexthop dev ppp0 weight 98 realm 101 nexthop dev ppp1 weight 99 realm 102
22:05:28    message repeated 3 times
22:05:29    Failover monitor has started
22:07:36    Default Route has been changed: nexthop dev ppp0 weight 1 realm 101 nexthop dev ppp1 weight 99 realm 102
22:07:37    message repeated 3 times
22:07:38    Failover monitor has started
22:07:46    Default Route has been changed: nexthop dev ppp0 weight 1 realm 101 nexthop dev ppp1 weight 1 realm 102
22:07:47    message repeated 3 times
22:07:48    Failover monitor has started


Configuration follows, if you can find anything wrong with it, I would appreciate a shout!



Back to top
View user's profile Send private message
DrmCa



Joined: 12 Apr 2011
Posts: 199

PostPosted: Tue Dec 24, 2013 4:13 pm    Post subject: Reply with quote

In total desperation I tried 2.0RC3 and still no load balancing with this config. Help! :~(
Back to top
View user's profile Send private message
DrmCa



Joined: 12 Apr 2011
Posts: 199

PostPosted: Thu Jan 16, 2014 9:04 pm    Post subject: Reply with quote

Solved by upgrading to v.3.0 where load balancing is native.
Back to top
View user's profile Send private message
hubertmatthews



Joined: 31 Jan 2014
Posts: 1

PostPosted: Fri Jan 31, 2014 5:35 am    Post subject: Reply with quote

That's good i appreciate your information.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    www.zeroshell.org Forum Index -> ZeroShell All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group