www.zeroshell.org Forum Index www.zeroshell.org
Linux Distribution for server and embedded devices
 
 SearchSearch  RegisterRegister  UsergroupsUsergroups 
 ProfileProfile  Log inLog in  Log in to check your private messagesPrivate Message 

Remote access 4G from WAN

 
Post new topic   Reply to topic    www.zeroshell.org Forum Index -> ZeroShell
View previous topic :: View next topic  
Author Message
DVRS



Joined: 06 Apr 2014
Posts: 4

PostPosted: Sun Apr 06, 2014 12:03 pm    Post subject: Remote access 4G from WAN Reply with quote

Hello to everyone!

I have installed a 4G Huawei modem on Zeroshell succefully, but just having a problem with getting public access. We only have the 4G modem for internet access and also want to have remote access to our server in the office. This is also where our problem starts, we have a dynamic WAN IP but this can be solved with OpenDNS. Below I have some details I found in Zeroshell. I am just missing something but can't figure it out.

NAT = ppp0
ppp0 connected = inet 100.68.140.180 P-t-P 10.64.64.64
ETH00 Gateway = 192.168.0.75
Back to top
View user's profile Send private message
DVRS



Joined: 06 Apr 2014
Posts: 4

PostPosted: Mon Apr 07, 2014 7:41 pm    Post subject: Logs Reply with quote

20:33:35 pppd 2.4.3 started by root, uid 0
20:33:36 Serial connection established.
20:33:36 Using interface ppp0
20:33:36 Connect: ppp0 <--> /dev/ttyUSB0
20:33:38 Could not determine remote IP address: defaulting to 10.64.64.64
20:33:38 local IP address 100.68.140.180
20:33:38 remote IP address 10.64.64.64
20:49:40 Terminating on signal 15
20:49:40 Connect time 16.1 minutes.
20:49:40 Sent 51836 bytes, received 407356 bytes.
20:49:40 Connection terminated.
20:49:40 Hangup (SIGHUP)
20:49:40 Exit.
20:49:41 pppd 2.4.3 started by root, uid 0
20:49:42 Exit.
20:49:44 pppd 2.4.3 started by root, uid 0
20:50:00 Connect script failed
20:50:00 Exit.
20:50:04 pppd 2.4.3 started by root, uid 0
20:50:14 Connect script failed
20:50:14 Exit.
20:50:14 pppd 2.4.3 started by root, uid 0
20:50:16 Serial connection established.
20:50:16 Using interface ppp0
20:50:16 Connect: ppp0 <--> /dev/ttyUSB0
20:50:17 Could not determine remote IP address: defaulting to 10.64.64.64
20:50:17 local IP address 100.68.140.180
20:50:17 remote IP address 10.64.64.64
Back to top
View user's profile Send private message
redfive



Joined: 27 Aug 2009
Posts: 232

PostPosted: Tue Apr 08, 2014 7:43 pm    Post subject: Reply with quote

Hi DVRS, what do you mean with "This is also where our problem starts" ? What exactly is your goal and how are you trying to reach it ? What works and what doesn't ? I can only see that ppp interface has gone down and then is up again...and your public ip address....a bit more info would help.
Regards
Back to top
View user's profile Send private message
DVRS



Joined: 06 Apr 2014
Posts: 4

PostPosted: Wed Apr 09, 2014 7:47 am    Post subject: Reply with quote

Hi Redfive, thanks for your reply.

We have our 4G modem working (internet) but we also want to access our office from outside. If we want to connect to our servers we need forwarding IP or VPN. The public IP we get from our ISP is dynamic (92.xxx.xxx.xxx), the 4G modem gets a local IP starting with 100.xxx and remote IP is 10.64.64.64 I think the problem is caused by the APN we have to use, but I am not sure.

I want to know if its possible to change the modem remote/local IP settings?

Regards,
Back to top
View user's profile Send private message
DVRS



Joined: 06 Apr 2014
Posts: 4

PostPosted: Mon Apr 14, 2014 7:20 am    Post subject: Reply with quote

Issue solved, ISP uses transparant proxy.
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    www.zeroshell.org Forum Index -> ZeroShell All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group