www.zeroshell.org Forum Index www.zeroshell.org
Linux Distribution for server and embedded devices
 
 SearchSearch  RegisterRegister  UsergroupsUsergroups 
 ProfileProfile  Log inLog in  Log in to check your private messagesPrivate Message 

DHCP stopped working

 
Post new topic   Reply to topic    www.zeroshell.org Forum Index -> ZeroShell
View previous topic :: View next topic  
Author Message
DrmCa



Joined: 12 Apr 2011
Posts: 193

PostPosted: Wed May 07, 2014 11:43 pm    Post subject: DHCP stopped working Reply with quote

Noticed that the clients can no longer acquire IPs from DHCP and every 10 seconds getting this in the DHCP log:

Code:
19:41:09    Internet Systems Consortium DHCP Server V3.1-ESV
19:41:09    Copyright 2004-2010 Internet Systems Consortium.
19:41:09    All rights reserved.
19:41:09    For info, please visit https://www.isc.org/software/dhcp/
19:41:09    Wrote 11 leases to leases file.
19:41:09    
19:41:09    No subnet declaration for VPN99 (192.168.250.254).
19:41:09    ** Ignoring requests on VPN99. If this is not what
19:41:09    you want, please write a subnet declaration
19:41:09    in your dhcpd.conf file for the network segment
19:41:09    to which interface VPN99 is attached. **
19:41:09    
19:41:09    Listening on LPF/ETH00/00:06:5b:61:b1:28/10.10.10/24
19:41:09    Sending on LPF/ETH00/00:06:5b:61:b1:28/10.10.10/24
19:41:09    Sending on Socket/fallback/fallback-net
19:41:09    There's already a DHCP server running.
19:41:09    
19:41:09    If you did not get this software from ftp.isc.org, please
19:41:09    get the latest from ftp.isc.org and install that before
19:41:09    requesting help.
19:41:09    
19:41:09    If you did get this software from ftp.isc.org and have not
19:41:09    yet read the README, please read it before requesting help.
19:41:09    If you intend to request help from the dhcp-server@isc.org
19:41:09    mailing list, please read the section on the README about
19:41:09    submitting bug reports and requests for help.
19:41:09    
19:41:09    Please do not under any circumstances send requests for
19:41:09    help directly to the authors of this software - please
19:41:09    send them to the appropriate mailing list as described in
19:41:09    the README file.
19:41:09    
19:41:09    exiting.


What should be done to fix DHCP?

Thank you!
Back to top
View user's profile Send private message
DrmCa



Joined: 12 Apr 2011
Posts: 193

PostPosted: Thu May 08, 2014 3:36 pm    Post subject: Reply with quote

So far I tried to delete and re-create the network, reboot the server, but DHCP still dumps error about 'already running' into the log.

ps shows that dhcpd is running, but it does not serve the client requests.

I tried dhcping from the clients but got 'no answer'.

Any ideas?
Back to top
View user's profile Send private message
DrmCa



Joined: 12 Apr 2011
Posts: 193

PostPosted: Thu May 08, 2014 11:39 pm    Post subject: Reply with quote

When doing dhcping there is a new record in the log, but still no answer:

19:35:54 DHCPREQUEST for 10.10.10.3 from 00:00:00:00:00:00 via ETH00: unknown lease 10.10.10.3.

Tried deleting dhcpd.pid and rebooting, then checking if pgrep gave the same PID as contained in the new dhcpd.pid - they are same, so no discrepancy between running process and its pid file.

I am really running out of options other than to re-format the box and rebuild from scratch.

Any ideas??? Fulvio to the rescue!!!
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    www.zeroshell.org Forum Index -> ZeroShell All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group