www.zeroshell.org Forum Index www.zeroshell.org
Linux Distribution for server and embedded devices
 
 SearchSearch  RegisterRegister  UsergroupsUsergroups 
 ProfileProfile  Log inLog in  Log in to check your private messagesPrivate Message 

VPN tunnel to handle traffic

 
Post new topic   Reply to topic    www.zeroshell.org Forum Index -> ZeroShell
View previous topic :: View next topic  
Author Message
frarugi



Joined: 21 Jan 2016
Posts: 2

PostPosted: Thu Jan 21, 2016 2:58 pm    Post subject: VPN tunnel to handle traffic Reply with quote

Hello
I have a device with one ethernet port (ETH00) and one WWAN interface (in the test machine it is another ETH port, but can be a different peripheral).
I already configured it to act as a router, so all the internet traffic coming from the ETH00 is redirected to the other port.

Now I wanted to make a VPN tunnel towards another PC, so that all the internet traffic coming from ETH00 is re-routed throgh the VPN. For this reason I setup another machine with an OpenVPN server. Now if I take my pc and open an OpenVPN connection to the server I redirect all my traffic through that interface. Wonderful.

I want to replicate this on my zeroshell machine, though. But I don't know how. In the end, the ZS machine should just route all the traffic from the ETH00 to the vpn, ut I can't get it to work. If I try to ping something from the ZS shell I can (and it passes through the VPN), but if I try to ping from a machine attached to ETH00 it fails.

I opened a wireshark session on the OpenVPN server and I see that the ping request packets arrive, but the replies are only shown for the locally-generated pings.

What can I do to solve this?
Sorry if this message was quite confused.. If you need more infos just ask
Back to top
View user's profile Send private message
frarugi



Joined: 21 Jan 2016
Posts: 2

PostPosted: Thu Jan 21, 2016 4:23 pm    Post subject: Reply with quote

Never mind, I figured it out...
I hadn't enabled the NAT for the interface, so packets were not translated (and so probably they were rejected somewhere after they arrived in the server). I added the VPN to the NATted enabled interfaces and now it is working
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    www.zeroshell.org Forum Index -> ZeroShell All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group