www.zeroshell.org Forum Index www.zeroshell.org
Linux Distribution for server and embedded devices
 
 SearchSearch  RegisterRegister  UsergroupsUsergroups 
 ProfileProfile  Log inLog in  Log in to check your private messagesPrivate Message 

Strange CPU load chart since migration from 3.0.0 to 3.5.0

 
Post new topic   Reply to topic    www.zeroshell.org Forum Index -> ZeroShell
View previous topic :: View next topic  
Author Message
DrmCa



Joined: 12 Apr 2011
Posts: 218

PostPosted: Thu Jun 23, 2016 11:36 pm    Post subject: Strange CPU load chart since migration from 3.0.0 to 3.5.0 Reply with quote

Last night at 7 PM I migrated to an Atom machine to conserve energy costs and installed 3.5.0
Since then as you can see from the attached daily 5min CPU load chart, the load is horisontal at about 15%. Previously it spiked up and down.

Makes me wonder if there is a problem with CPU load reporting on this new version.



This does not jive with top in the shell prompt:

Code:
top - 19:38:16 up 11 min,  1 user,  load average: 0.00, 0.06, 0.06
Tasks: 118 total,   1 running, 117 sleeping,   0 stopped,   0 zombie
Cpu(s):   0.3% user,   0.3% system,   0.0% nice,  99.2% idle,   0.2% IO-wait
Mem:   2062160k total,   214716k used,  1847444k free,    23180k buffers
Swap:   131068k total,        0k used,   131068k free,    65188k cached

  PID USER      PR  NI  VIRT  RES  SHR S %CPU %MEM    TIME+  COMMAND
 9319 root      20   0  3516 2784 2464 S  0.3  0.1   0:00.87 failoverd
23594 root      20   0  2756 2084 1832 R  0.3  0.1   0:00.11 top
    1 root      20   0  2204  448  404 S  0.0  0.0   0:00.70 init
    2 root      20   0     0    0    0 S  0.0  0.0   0:00.00 kthreadd
    3 root      20   0     0    0    0 S  0.0  0.0   0:00.68 ksoftirqd/0
    4 root      20   0     0    0    0 S  0.0  0.0   0:00.00 kworker/0:0


Does anyone else observe the same problem?
Back to top
View user's profile Send private message
fulvio
Site Admin


Joined: 01 Nov 2006
Posts: 1072

PostPosted: Fri Jun 24, 2016 3:17 am    Post subject: Reply with quote

Last Zeroshell releases better use multicores system by distributing hardware interrupts on all cores. This result in a lower system load. In addition the last releases report in the system load graphic the value LOADAVG/CORES*100 and not LOADAVG*100 as in the past. In any case, your system load graphics is strange because the graphic is too uniform. Probably something is not working correctly in MRTG.
Regards
Fulvio
Back to top
View user's profile Send private message Send e-mail
DrmCa



Joined: 12 Apr 2011
Posts: 218

PostPosted: Fri Jun 24, 2016 2:49 pm    Post subject: Reply with quote

Yes, this is an Atom with HT on so would be treated as multi-core system I guess.

Since posting I restored another slightly different backup of the original profile (it only had a bit more VPN setup, like another user/certs added), nothing major. Since activation of that restored profile CPU load fell and is now near 0% with some spikes that make sense.

Thank you for looking into this!

Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic   Reply to topic    www.zeroshell.org Forum Index -> ZeroShell All times are GMT
Page 1 of 1

 
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum


Powered by phpBB © 2001, 2005 phpBB Group