Reply To: WPA Howto

Forums Network Management ZeroShell WPA Howto Reply To: WPA Howto



First, let me say that I’m very new to Linux and know very little about WPA/WPA2 Enterprise. (Only that it is the most secure wireless you can use today. I’m very paranoid about my network security as my day job is with routers/switches for a major retailer in the US.)

In my search for an “appliance” that would perform WPA Enterprise for my local wireless network, I came across zeroshell. I have a spare net4801 from my Monowall development days that I thought would be great for this purpose. I haven’t ran across anything telling how to install the image to a flash disk though, so before trying to figure that out myself, I tried the ISO version in a virtual machine under Parallels. (I imagine that I could simply write it using the same tool that Manuel puts out to write images for Monowall, but didn’t know if that would work for a linux based system.)

For someone familiar with the whole WPA Enterprise/CA thing Zeroshell is probably great. In my case, however, I am lost. I don’t know what the process is for setting up WPA Enterprise utilizing CA’s and usernames w/ passwords, even with the nice webGui tools you provide. That’s why I was hoping there was a guided screenshot tour, or something to let me know how to set it up.

Currently, I’m using a service called to handle my WPA Enterprise wireless, but if there is any prolonged interruption in their Internet connection (as was the case yesterday for several hours), my wireless network goes down. It’s only a home network, so there is no money riding on it working, but perhaps you can relate to a wife who has suddenly lost Internet connectivity when she’s in the middle of sending out an email or posting on a message board. The recent witopia outage wasn’t the reason that I was looking for a replacement… Having the radius server not on a local network has been a problem for me from the start, but since I had been unsuccessful in my previous attempts to get it working on a local machine and because witopia worked and was free, I used it.

At any rate, I was looking for a bit more in the way of documentation to lead me through the proper steps of getting WPA Enterprise up and running. If I can manage to get it working in the VM I can load it onto the net4801 and try it out there.

As a side note, developer related documentation would be greatly helpful. The documention put out by the Monowall team enabled me (someone with very limited FreeBSD experience before Monowall) to be able to get a development system up and running quickly and actually contribute several significant features to the code base. I can’t tell what Zeroshell is using as the webGui language, but if it is something that enough people have a good bit of knowledge about (like PHP), there is a chance that you can get a talented team together to work on this specialize distribution…