Reply To: Strange WPA Enterprise issue

Forums Network Management ZeroShell Strange WPA Enterprise issue Reply To: Strange WPA Enterprise issue


One other unusual thing about this setup: I’m using public IP Addresses on zeroshell and the access points.

I don’t really see how this could cause this behavior, but today I loaded my home config on the zeroshell machine at work and we created a lab environment that pretty much matched my home, as far as IP Addressing goes. It worked fine with our test hardware (laptop, AP, and Zeroshell server).

We then moved it to our production network, changed the IP Addressing of the zeroshell machine and the AP to public IPs and modified the Access Point section in Zeroshell to use the new (public) IP address of the AP (keeping a simple test shared secret) and pointed the AP to the new (public) IP of the zeroshell machine. Logging in via wireless would result in a connection for only a few seconds. I could actually get a few pings from the wireless client to the zeroshell server, then it would drop off.

After this failure, I tried this test:
1. I enabled the DHCP server on the AP
2. I attached zeroshell directly to one of the Ethernet ports on the AP
3. I enabled the NTP server on zeroshell
4. I configured the AP to use zeroshell as its NTP source
5. I disconnected the link to the production network

In this scenario, the production Ethernet switches are out of the loop, as is all Internet connectivity. In this case, the laptop would connect, grab an IP Address from the AP, get a few pings and replies from the wireless client to zeroshell, then lose connectivity.

So, at this point, I’ve eliminated hardware (since it worked fine with my original configuration using private IP Addresses, and the production hardware is not in use). Very minimal config changes were made to move the config to public IP Addresses. I don’t see how private vs. public addresses would cause this problem…

Why isn’t this working??? Anyone else using public IPs on the zeroshell and their AP’s?