Reply To: [SOLVED] Accesing local servers using the domain name.

Forums Network Management ZeroShell [SOLVED] Accesing local servers using the domain name. Reply To: [SOLVED] Accesing local servers using the domain name.


Indeed, your guess is almost correct in all aspects.

Here it comes a detailed explanaition of my topology.

I have a cable modem isp connection attached to ETH1. This modem is subneted by the ISP, for example if i do a traceroute the response is this.

traceroute to (, 30 hops max, 60 byte packets
1 ( 0.249 ms 0.226 ms 0.167 ms
2 ( 9.198 ms 9.206 ms 9.194 ms
3 ( 9.493 ms 9.502 ms 9.495 ms
4 (200.52.x.x) 72.901 ms 72.903 ms 72.878 ms

Where 200.52.x.x is my public ip and is the ip of the ETH1 interface in Zeroshell provided by the cablemodem dhcp. is a subnet not done by me, this is produced by my ISP but that should not interfeer cause I have a special contract for companies where they ensure me that my cable modem is in some kind of DMZ. In other words pinging 200.52.x.x is related to my bussiness an no other one. In fact before implementing Zeroshell I was able to access my intranet services outside and inside the lan whith no problem having every computer in the 10.62.0.x subnet directly attached to the cable modem using a switch.

ETH2 is software and hardware department subnet. (192.168.2.x) and Eth3 will be contability and administration department subnet (192.168.3.x not yet implemented the cable is unplugged just like you comment)

ETH0 is unplugged but at some point I will be plugging it to my second ISP provider (This was the main reason for implementing Zeroshell)

I only have one server in but i dont need external access to this cause this host only local services like sourcesafe, WINS, and some contability services. (Thats why this do not apper in the tables)

I have another server in (the one that is breaking my brain), this host my web page, a web app in port 8100, subversion in https, ftp , etc.

And lastly is not a server is just a computer of one developer that need the port 600 to test a GPRS app.

My domain is hosted in DynDNS and Im completely sure that this is working. If I ping this is always traduced to the correct public ip 200.52.x.x

Related to your last question, Im afraid Im not really know the way my cable modem is configured but like I said I can ensure you that this is working like a DMZ cause if I unplugg the Zerosell and plug my computer and run a simple program that start listening to a TCP port and try conecting to that sockets using other ISP connection it works flawlesly.

I hope this clarify a little the topology and sorry, you are completely rigth, my first post was not exactly clear. 😥