Reply To: slapd stuck?

Forums Network Management ZeroShell slapd stuck? Reply To: slapd stuck?


Hmmm, I just had this happen again while trying to add a brand new DNS A record. That moves this from annoying issue that can be worked around, to bug that makes my system impossible to administrate.

Having to manually re-enter all of my settings from a fresh build doesn’t seem acceptable to me.

Just to recap, whenever I attempt ANY modification to a DNS entry, either adding a new one or deleting an exsiting one, the DNS subsystem locks up, named stops responding to queries, and LDAP’s slapd process sits using 99% of the CPU for as long as I let it hang.

One forced reboot, LDAP Recovery also sits and hangs for as long as I’m willing to leave my network offline. The only option I’m left with is to restore a backup of my USB stick, which works but doesn’t allow me to make any changes to the DNS system.

My backup was from version 1.0.beta14, and I have tried booting with both b14 and b16 CD’s, neither one seems to make any difference. I believe I started using this at 1.0.beta12.

At some point, I will try to find the time to create an entirely new profile, natively under beta 16, and hand-enter ALL of my data again, but that’s several dozen DNS and DHCP entries, along with various firewall rules, QoS data, and other tweak I’ve likely forgotten. Not something I want to do more than once.

I realize you probably can’t replicate the issue on your end, but since everything is hidden away in LDAP (which I’m not familiar with), I’m not quite sure where to look to try and figure out the problem. Any hints are appreciated!