Re: hunch about zeroshell backup/restore problems

Forums Network Management ZeroShell Transferring Zeroshell Profile Re: hunch about zeroshell backup/restore problems


I see several times on the forum where people say that when they try to restore a profile through the web-interface, there is a message about error to restore profile (after quite a while).

I work mainly on the alix platform. These devices are plenty fast enough to unzip a backup file within a matter of seconds normally. I believe the reason that it takes so long before eventually failing (and if you examine the files, they are only partially there), has to do with the time setting on the zeroshell. I have a hunch that there is a message being sent somewhere (possibly com2???) that says “warning: unzipping a file that is newer than the current system time.” The message will have to be repeated for each file that is unzipped and the speed at which it can send the message is likely very slow (possibly because of the rate of the serial interface).

Last time I needed to do a profile backup/restore, I tried all of the usual tips like deactivating the main profile before restoring and/or copying the original profile and making a backup of the copy. Neither of these tips worked for me and I don’t believe they are necessary steps.

I believe the true answer is simply setting the time of the zeroshell device to a date/time greater than or equal to the zeroshell device that you are restoring from. I think most zeroshell devices will have the incorrect time until they are on-line long enough to set themselves.

Lastly, I didn’t have a reason to test my above theory using the web-interface, but I do want to encourage anyone that is nervous about backup/restore that the manual methods are very straight forward and more fool-proof. Here is my alternate strategy if the web-interface option does not work:

1. create a tar.gz file of the profile that you want to backup (log in through ssh)
2. sftp the tar.gz file to an alternate host (almost any server/device that you can ssh to would be able to accept the file)
3. connect your new zeroshell device. set up minimal internet connectivity (takes about 2 minutes)
4. log in to the new zeroshell device with ssh; use sftp to get the backup file
5. unzip the backup file into the profiles directory
6. activate the profile

Using the above procedure is where I stumbled upon the possible delay in restoring. A debug message is displayed on the screen warning about the time for every file that is being unzipped. I waited for about 15 minutes for the unzip to complete before I got tired of it. I canceled the unzip, set the correct time, and started the unzip again. It took maybe 3 seconds.