Re: My Fix


I am having the same problem with B15 & B16. I needed to delete a user account a create a new one. The slapd process goes to %100 and never (waited an hour) finished.
Since my system is on CF, to get things running again. I just created a new CF, restored from backup but I tried again. Same problem!
So I went back in steps, to B15, then all the way back to B12 trying every version. But since I did not keep my backups from when the system was B12 and was restoring backups created by a newer version (not %100 sure, but I think the oldest I’ve kept is from B14) I was never able to get past the problem. Any change to LDAP would cause the same problem.

Taking a hint from a post somewhere else on here (if I find it again, I’ll link to it so the author has proper credit!) I’ve tried this and it seems, so far, to have fixed the problem for me.

I’m using B16 and following these steps:
Change to, create a profile, modify the default profile. Whatever you need to either use the console, or gain remote access. Don’t worry about setting it up %100. I just needed the correct IP on ETH0, SSH and HTML access (my system is headless) and I’m modifying the default profile for my needs.
I then restored my backup which becomes the 2nd profile on my system. Don’t activate it yet!
SSH to the system. Login as “admin” and then at the menu type “s” for “Shell Prompt”.
Now that you are at a prompt, type in:
(Edit: Because I can’t seem to get the “Code” function to work on here. You may not be able to cut and paste this to your SSH terminal. Sorry!)

cd /DB/_DB.002/var/openldap-data/
mkdir bak
mv __db.* ./bak/

_DB.002 might be different on your system. You will need to determine if this is the case, and which one is correct for your system on you own. I also have had no reason to restore the files in bak, but I am keeping them just in case for now.

Now activate the profile and your LDAP problems should be fixed!

I have built a duplicate of my live system and plan to spend a little time making backups with versions starting with B12 and go forward upgrading to see at what point things seem to start causing this problem. But it’s not going to be very easy for me as my live system has 3 Nic’s a VPN and a WiFi Captive Portal.