Re: Still no way, despite should work

Forums Network Management Networking wildcard dns Re: Still no way, despite should work


First there is nothing usable in the named.conf, and I could not find any other text file participating in the definition of the zone. Only binary in the /DB/…

The definition with the wildcard “*.my-domain.lan. A special-IP” persists, so it is recognized as valid by ZS’s GUI.

Then I changed to a simple * because the resulting display (blue label) is actually
*.my-domain.lan (without trailing dot)
…while the full wildcard leads to
* (this is suspect…)

…but in any shape it does not work, always NXDOMAIN.

According to the RFC cited above, it should, unless we fall under that restriction: “when the query name or a name between the wildcard domain and the query name is know to exist”. Here my query is not in the explicit definitions, so the wildcard should catch it.

Then reading that:
…I figured that there could be an option to enable wildcards, or a particular defintion to do, but found nothing related in what I can see of ZS.

Is there an expert who understands it better ?
Is it a bug ? A wanted restriction ?
Could someone setup a workaround, not using an explicit list of subdomains to be caught ?

Thanks, Best regards.