3.8.1 upgrade broke nDPI

Forums Network Management ZeroShell 3.8.1 upgrade broke nDPI

  • This topic is empty.
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #44897

    I was running 3.7.6 (I think) and clicked the upgrade button from package manager. When Zeroshell rebooted, most of the firewall rules were broken.

    Firewall was heavily utilising nDPI. On closer inspection, some of the nDPI protocols had broken references. They show in the rule table, but opening nDPI picker, the lines are blank in the selected protocols. eg FTP Control and Data.

    Even after fixing all these, and reapplying every rule that includes nDPI, it still isn’t working for most protocols. I’ve had to add rules by port number to get any traffic through the firewall.

    What gives? Kernel is 4.4.95-ZS, The only other package I have installed is NTOP 40e00 v2.4.




    Same thing here, i was using ndpi in version 3.6.0 for some firewall rules that were working as they should, are not working any more in 3.8.1 version.

    I tried deleting existing rules and made them again but still doesn’t work.

    Any one else experiences this?


    Hi easpem,
    Do you have the ntop package installed? since nDPI is from ntop, maybe there is a inter-version compatibility problem. That’s all I can think of, and explains why this is apparently not a widespread issue.


    Could you try with a fresh installation?


    No additional packages installed. Ill try in a fresh installation, since a facebook ndpi rule is working fine. bittorrent is the one failing.

    Thanks for your help, ill report back ASAP


    I did try the same ndpi firewall rules on a fresh installation and they work fine.

    So i deleted all my firewall rules on the production router, then restarted and made every rule again and now seems to be working again.

    Is there a way to export firewall rules to a file in order to restore them o share them amongst other zeroshell routers? the same thing would be awesome fot the dchp static leasings.

    Thanks for the support, and this great software!

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.