about half speed with zs

Forums Network Management Networking about half speed with zs

  • This topic is empty.
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #43509

    Hi! I just connected a modem cable on zeroshell and I made some speed test

    without zs I dl @ 30mbps and ul @ 3 mpbs

    with zs I dl @ 12~14mbps and ul @ 3 mbps.

    (both interfaces are >=100mpbs)

    i don’t get it. I dont have any qos or net balancing activated.

    I activated dhcp and nat and that’s all

    I m new to this so I didnt play with the others options in zs.


    Wow, this is interesting. Could it be hardware related? Maybe a slow processor is having a hard time handling 30Mbps NATting?


    I have the same problem. My line speed is 10 mbps.
    When I use my old fritzbox router, the download rate matches the line speed,
    with ZS the download rate is 5-6 mbps.

    My ZS is running on an AMD E4200+ (2×2.2GHz). The cpu usage is about 2%. Both network interfaces are 100mps.

    I think the hardware I use is able to handle much higher speeds. I already checked the settings and can’t find an explanation.

    What can I do to find the cause?


    Does anyone have an idea about this problem? Or any experience with the performance of zs, especially using pppoe?
    It would also help to get a few hints how to find the bottleneck.

    The download rate of my zs is the only problem I have with it. In my opinion zs is the best router distribution availabe for free.


    this seems to be the same issue I have with vdsl. the ppp0 mtu rate seems to be lower than rated. if you do an ip link show at the shell you’ll see that mtu for ppp0 should be set to 1492. BUT if you go to http://www.speedguide.negt and let check from the outside you’ll get 1452 which seems to be is too low to handle unfragmented packets fast enough.
    I have nothing found on this issue nowhere. And the programmers don’t say a word to this.
    Hopefulle they get this issue managed


Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.