[ALIX / ZS v.3.8.1] Connectivity lost on switching the WiFi

Forums Network Management Signal a BUG [ALIX / ZS v.3.8.1] Connectivity lost on switching the WiFi

  • This topic is empty.
Viewing 1 post (of 1 total)
  • Author
  • #44896


    Bad news, I had to fallback 3.8.1 -> 3.7.1 due to this problem. 😥

    After upgrading, all was working fine, until I knocked to activate the WiFi. 😯

    Reminder: On my systems the WiFi is not permanently active, it is activated by knocking then auto-shuts off when the connection is idle. This is described here:

    The problem is not due to my scripts, since all had been working fine with ZS 3.7.1, and works again after the fallback,
    …then I could get the same issue on 3.8.1 by just ticking/unticking the checkbox “Up” for WLAN00 in the page “Network” of the GUI.

    I cannot tell exactly whether it is a crash of the network services, or a hang while processing the change that prevents a reactivation, but what happens is:

    1) The Alix immediately becomes non-responsive on LAN-side bridge (the WiFi is bridged to this one). The WAN side still responds to ping but of course offers no access.
    2) Soon after, my script detects that the device is disconnected and reports it by flashing the Led as expected for an error.
    3) The only solution then is to power off/on to reboot. 👿
    4) After reboot all is stable again, as long as I don’t try to switch the WiFi.

    Technically the knock handler does this:

    ifconfig WLAN00 up (or down on idle)
    /etc/rc.d/init.d/network restart
    then only for up it calls:
    /root/kerbynet.cgi/scripts/start-wifi norestart

    The crash or hang appears to occur inside this script that also handles the checkbox.

    Due to the need to reboot, I could not get much for a post-mortem at this time.

    ❓ Did someone else encounter the same issue ?
    I guess that most of Users don’t switch the WiFi often… But one day or another they will…

    Thanks, Best regards

Viewing 1 post (of 1 total)
  • You must be logged in to reply to this topic.