APU2c4 installation issue

Forums Network Management Embedded Devices APU2c4 installation issue

  • This topic is empty.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #44619

    This week I finally decided to order a PC Engines APU to replace my 15 year old AMD Opteron.
    I have struggled to get the image to the internal msata drive. after 1 day I finally get the Zeroshell to boot from the internal drive and I can select the image.

    However no it is stuck with the “Please wait . loading the Kernel.

    Any suggestions hints on how to get past this hurdle ?


    I am still struggling with this setup.

    I have tried to copy different images to the internal m-sata drive and they all fail at the same stage.

    I tried the other route and tried to tweak the grub.cfg and try to boot it manually. Still no success. I tried it manually and it seems to boot but then goes into a reboot.

    To say that I am frustrated would an understatement. It would be great if anybody had any hints on where to look to fix this


    OK I sorted out the issue with the help form the guys over on the PCengine formun.

    The issue was that after the start of the kernel. the terminal speed is changed from 115200 to 38400 once I connected with the new speed I was able to wrok from there.

    Load from a usb drive. then run the install option to the m-sata drive.

    one trick for me was that on boot it would not recognize the usb drive I had to boot and then with F10 go into the setup mode. make no changes, save and reboot and the usb drive was readable.

    it is all good now. will try to replace the production FW next week and will let you know how it performs


    I’ve been into this pain.. but having an alix helped me.
    Basically the ISO image supplied for ZS is a VGA while APU require a serial.

    I did it blindly, created an image on a stick, tested on a computer then insert it into APU. After boot I connected my laptop, assigned a static IP and used the browser to connect to

    From GUI ( SETUP -> BOOT ) I changed the Console from VGA to Serial 115200 and then rebooted. Now the serial cable worked as it should and I was able to transfer the image.

    I wanted to post my experience but beeing so cumbersome I wanted to investigate what files are changed on the image and then post a simple how to. Unfortunately I was more busy compiling the missing bits for APU ( LEDs, buzzer, GPIO, temperature ) .
    You can get the APU missing drivers from here: http://jb68.com/pkg/
    I also developed some LED scripts for APU GPIO with ZS that I am going to publish soon.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.