AR9160 Cannot configure for 5GHz N Access Point (wrong chann

Forums Network Management Wireless Networks AR9160 Cannot configure for 5GHz N Access Point (wrong chann

  • This topic is empty.
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #43970


    I’m new to the forum and ZeroShell. I’ve tried to setup and Access point on an old laptop using an atheros AR9160 mini pci wifi card. It’s dual band but single radio (only 1 band of the two can be active). That’s fine with me, since I only wanted to add this software AP to complement my single-band DIR-655 which doesn’t have 5GHz band.

    The card came from a DIR-628 router that doesn’t have gigabit. Speed testing with the 628 router showed that even though the wireless portion could connect on 5GHz up to 270 Mbit/s, the Ethernet portion of the data path killed the speed to about 80MBit/s REAL transfer in either direction, practically same REAL speed I was getting with the DIR-655 2.4GHZ band and 150 Mbit/s connection.

    Hence the need to use it on a gigabit capable computer/laptop to make use of the full wireless bandwith the card can provide.

    Ran from USB key


    1) Zeroshell web interface does not support configuring the Wifi (as per the error message below):

    “This version does not include the web interface support for the WiFi. To manage the Wireless devices you need to run the wifi-manager script from the console by using a serial, VGA or ssh session.”

    The only way of configuring the wireless is via option “W” on the console screen (VGA)

    Is there any other recommended version that would include wifi configuration via web interface? Would it support the ath9k drivers?

    Second problem (the most important)

    2) WiFi Manager on the console does not configure the card properly (does not present the correct channel list for the wireless N 5GHz band, but offers channels 1-11 of the 2.4 band instead)

    Wireless Card: (as detected)
    Qualcomm Atheros AR9160 Wireless Network Adapter [AR9001 802.11(a)bgn] (rev 01)

    Invoking the Wifi Manager, option


    Regulatory domain: CA
    Select the wireless card: (enter)

    country: CA

    (2402 – 2472 @ 40), (3, 27)

    > 2.4GHz frequencies

    (5170 – 5250 @ 40), (3, 17)

    > 5GHz frequencies
    (5250 – 5330 @ 40), (3, 20), DFS

    > 5GHz frequencies
    (5490 – 5710 @ 40), (3, 20), DFS

    > 5GHz frequencies
    (5735 – 5835 @ 40), (3, 30)

    > 5GHz frequencies

    Wifi device you want to configure the Standard/Channel/Power [wlan0]

    <0> Auto
    <1> 802.11a (5 GHz 54 Mbit/s)
    <2> 802.11b (2.4GHz 11 MBit/s)
    <3> 802.11g (2.4GHz 54MBit/s)
    <4> 802.11n (2.4GHz)
    <5> 802.11n (5GHz)

    Standard: [5]:

    After selecting option 5 (Wifi N, 5 GHz band) I get presented with the WRONG selection of channels. (channels 1 to 11, 2.412 GHz to 2.462 GHz). This is NOT the 5GHz band that I want.

    Channel 01 : 2.412 GHz
    Channel 02 : 2.417 GHz
    Channel 03 : 2.422 GHz
    Channel 04 : 2.427 GHz
    Channel 05 : 2.432 GHz
    Channel 06 : 2.437 GHz
    Channel 07 : 2.442 GHz
    Channel 08 : 2.447 GHz
    Channel 09 : 2.452 GHz
    Channel 10 : 2.457 GHz
    Channel 11 : 2.462 GHz

    Picking whichever channel from the (wrong) list presented, let’s say channel 11. ENTER


    Reloading Wi-Fi kernel module (ath9k)

    Creating virtual WiFi interfaces

    WLAN00(wlan0) (Mode: AP) Sec:wpa-psk SSID:Mywifi Status:UP)

    rmdir[ctrl-interface]: No such file or directory

    WLAN00: IEE 802.11 Configured channel (11) not found from the channel list of current mode (2) IEEE 802.11a

    WLAN00: IEEE 802.11 Hardware does not support configured channel

    could not select hw_mode and channel (-4)

    WLAN00: Unable to setup interface

    Manually entering a correct channel for this band (eg. channel 40) does not work.

    Is it possible to verify/edit the commands in this script to make sure it shows the correct channel list?

    Everything indicates that this card is supported and that the band is supported. However the script isn’t working properly.

    Is this a bug in the program?


    had the same issue with Apple AR5BXB72 on ZeroShell 3.3.2….. if I select 802.11a 5ghz it will give proper channels but I tried out a few and non of my laptops were able to see the access point


    ~10 months on and still no 5GHz option


    yeah it’s really to bad, this atom with dual mini pci-e slots is begging to become my wifi access point but still can’t get it to work


    I was able to replicate this bug. I am going to look into this week.
    As a work around, looking at code seem a simple issue and I can tell right away that you you can pick 0 and then you will have all channels to pick from 😉
    However after testing, the card does not come back so there are more issues on both wifi-manager and start-wifi scripts. Basically the script cannot distinguish between 2.4n and 5n.
    I need to read more about how command line works on wifi card.


    I was wrong, there was only a simple bug on wireless-manager script. Here is the fix:

    I’ll create a patch soon for people who don’t know how to do it.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.