Cann’t connect to Accesspoint

Forums Network Management ZeroShell Cann’t connect to Accesspoint

  • This topic is empty.
Viewing 11 posts - 1 through 11 (of 11 total)
  • Author
  • #40909


    I have setup a zeroshel box with a 3com wifi card and created one ssid with wpa-psk and zeroshell as accesspoint. My clients can’t connect. Have anyone got bridged wifi conns working? Found this on madwifi’s homepage…

    General note about bridging ¶
    If you’re bridging between the wireless and wired (ie using brctl), you must add a line such as:

    or whatever the bridge name you are using to the config file, or the WPA key exchange packets will get eaten by the bridge.

    Zeroshell’s bridges are named BRIDGE00 and so forth. Could this be an incompatibility betwen madwifi and zeroshell?

    Yours /sodMetaldream


    When you configure a Virtual SSID to be member of a bridge, Zeroshell automatically set the variable bridge=BRIDGE00 in the hostapd’s configuration file and set WDS=1 for the VAP by using iwpriv.
    I think the your wifi card could be not 100% compatible with MadWifi modules.
    Do you have tried with plaintext instead of PSK?
    Do you have tried with another client with a different wireless card?



    I have tried two diffrent clients but I’m afraid that you are right when you say that the card is’nt compatible.

    My question in this forum: Please name 1 card from a decent manucaturer that ABG and detachable antenna and that is FULLY supported in madwifi package. Preferable NOT DLINK as I have very bad experience with them…

    Yours /sodMetaldream


    You could look for a WiFi card on

    What is the chipset of your wireless network card?



    That compatibility site say that my 3com (3crdag675b) is compatible.

    The problem with the compatibility site is that no one take responsibility of the testing it’s the users that post something saying: Hey my card works… But the post doesn’t tell witch features of the madwifi package he/she had tested.

    So I did read the compatibility site and bought a card from a decent manufacturer that another user had stated worked…

    Therefore my question again is:

    Can you or somebody else name ONE PCI card that is WORKING (multi ssid AP prefereable ABG or BG) detachable antenna.
    Please this should not be hard

    More info on the card I have…. If it’s possible to get it working i’m willing to try…

    Compatibility site say:
    Wireless 11a/b/g PCI Adapter (3CRDAG675B)
    Chipset: AR5414(802.11a/b/g/turbo) (AR5006XS)
    Interface: PCI 3.3v (full & half-height)
    Antenna Connector: RP-SMA (RSMA)
    Device Information: 168c:001b (rev 01)
    Driver Revision: madwifi-trunk-r1325-20051111
    Notes: This card seems to be based on AR5006XS despite what lspci says. Turbo mode works fine (tested with iperf and a second, identical card).

    But my LSPCI states:
    Ethernet controller: Atheros Communications, Inc. AR5413

    Could this be the problem that it should load AR5006XS?
    One odd thing thoug is that the guy posting that the card worked say that his lspci stated 5414…

    My head is spinning PLEASE bring light into this world of strange behaviour

    Yours /sodMetaldream


    Hi Again no update?…

    havent anyone tried and got a pci card working?

    Yours /sodMetaldream


    Here is another update for you….

    I setup my old linsys accesspoint and connected to it as a client from zeroshell and inte worked like a charm. So I would say it’s an incompatibility.

    Is there anything i could try (load another module or something) if you read above the compatibility site states one thing and his lscpi states one chipset but my lspci states another one.

    If I would like to try to load the “compatibility”-stated chipsetmodule how would I do that in zeroshell’s console?

    And offcourse. Has’nt noone got a pci wifi card working as a accesspoint? Please let me know.


    Hello!? No one to comment?.

    Fluvio where are you?
    Have no one tried to connect a wlan card and setup zeroshell ass an accesspoint?


    For PCI WiFi I have successfully used two cards based on
    AR5416 and AR5212/AR5213 Atheros chipsets.



    Thanks for the reply. Understand that youv’e been bussy.

    Two Questions then:

    1. What brand and modelnumbers where those PCI cards?
    2. What commans is it to load another module for the card in zeroshell. If you look at erlier messages my lspci says one thing and the compatibility site states that anohter module should be used. I would like to test to see if it works…. (And I’m not a linux kind of guy so I need your help there)

    Yours sodMetaldream (Will try the Beta9 tonight)


    I have the same problem with my AR5416 pci wifi card. WPA+PSK doesn’t work with dhcp. Using plaintext or WEP works though.

Viewing 11 posts - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.