Captive portals and last version problems

Forums Network Management ZeroShell Captive portals and last version problems

Viewing 1 post (of 1 total)
  • Author
  • #64189

    Hello everyone,

    first of all thank you very much for this beatiful distribution.

    I have been using Zeroshell since beta 13 when it was only possible to run it via live CD and i like it very much.

    I must admit i am not one of the most proficient and it has way too many option for what i use it for but it’s done it’s job up until now (i use it as many people do in a hotel to handle the wifi credentials for guests by using the captive portal).

    It’s been a blast up until now and i improved stuff a lot since back then when i was running it in a driveless Tower pc. I have now set up a raspberry Pi 3 with everything installe dinto a SD memory card with a USB ethernet to have the internal hotel network separated from the customers.
    So my eth00 has the adress of the internal hotel network and eth01 has the one that is used for the customers.

    I always have had some little issue with some device, mainly because the specific person would reject the use of the certificate or had a pop-up blocker that killed the captive portal log in window. But all i had to do was tell them to write in the browser the adress of eth01 and perform the login from there so they could browse the web.

    1 week ago however i got a call from the owner of the hotel that said that a customer had the usual issue but this time the eth01 adress trick did not work. Also he claimed that the customer was actually an IT and thought that this could be an issue due to the fact that the router firmware wasn’t updated to the new security standards.

    So this got me curious and i went and checked and i found out that in his device (ipad with safari) the captive portal log in screen was indeed unreacheable. The error reported was too many redirects.

    So i started searching around the knowledge base of Zeroshell and found and tried many solutions, including redirecting to and disabling https. Finally i convinced myself to update (i had 3.7) so i backed up the db and burned the new iso into the SD card.

    Sadly, still no go. So i thought maybe something was going on with the IPAD of this specific customer and tried with my own phone that used to work. I have firefox in my phone and, to my surprise, i got an error, could not remember the exact words but still something that could summed into: wrong redirect.

    At this point i am sure that this is something related to something new as my phone was working pretty fine the last time i tried it with zeroshell.

    Surprisingly enough this does not affect everyone in the hotel, just a couple of customers. My laptop for example works fine and the owner’s cellphone do aswell.

    I have read many posts about this issue but none fixed it. And i just can’t seem to reach the Captive portal login page and the only solution i found for the moment was to take down CP completely. If i do so all devices are capable to browse internet, including the ones that weren’t working before. However the captive portal feature is too nice to pass out and it’s the whole purpose of the installation in my case.
    Does anyone knows how to fix this?

    Also it seemed that the raspberry was unable to boot sometimes (i have set an autoreboot script in zeroshell every 24 hours and i had to take it out otherwise the pi would get hung on boot and i had to physically disconnect the power plug several times until it manages to boot). About this i have seen a newly made topic made from another users with an answer from Fulvio that says that this is a known issue with the last version and he is currently investigating it.
    I guess the easiest way would be to roll back to a version that didn’t had this issue, could you tell me which one is the last one that works well with the raspberry?

    §Thank you very much for your answers in advance!

Viewing 1 post (of 1 total)
  • You must be logged in to reply to this topic.