Change HAVP denied page

Forums Network Management ZeroShell Change HAVP denied page

  • This topic is empty.
Viewing 8 posts - 1 through 8 (of 8 total)
  • Author
  • #41031

    First thanks to Fulvio Ricciardi excellent work.

    How can I change the ugly HAVP denied pages?


    Hi Charliee,

    You’ll need to edit/replace the .html files in /usr/local/etc/havp/templates. I have not done this, but that should do it.




    I tried to change the pages in the said directory, however i keep getting a read-only error, i tried mounting the file system in RW mode, but no luck ,can you help please

    P.S – Charlie any chance that you could get it working? let me on the knowledge




    Zeroshell, at least in the VMWare configuration, runs as a 2-part system. There is the ISO (read-only) and the database on the file system. I’m guessing here a bit that this is where you are running into the problem.

    Essentially, you need to do a few things:
    1. Identify which files to change.
    2. Copy them to the ‘database’ drive which isn’t read-only.
    3. Modify the files accordingly.
    4. Use the startup scripts to copy the new files into the running system at startup.

    I remember getting the hint while looking for a way to modify the HAVP configuration to allow for an external proxy. Searching these forums for the solution to pointing HAVP to an external proxy might give you enough information to do what you want. I remember that Fulvio gave the solution to the person who asked.


    I’ve been trying to acheive the same thing, ie make some changes to the havp html files in /usr/local/etc/havp/templates/en

    I created a preboot script to copy my modified files from /Database to the above directory but still get the read-only error; eg

    cp: cannot create regular file `/usr/local/etc/havp/templates/en/virus.html’: Read-only file system

    Should this be possible to do or am I trying to copy to the wrong location ?

    Cheers ๐Ÿ™‚


    ok, Ive managed to do it. It’s a bit of a hack though and I’d be interested in suggestions for a better way.

    First of all I created a directory tree – /Database/andy/usr/local/etc/havp/templates/en and copied the contents of /usr/local/etc/havp/templates/en into it.

    I modified the html files to suit.

    To make the modified files appear, I remounted part of the RO filesystem onto the directory under /Database using the post-boot script, ie;

    mount –bind “/Database/andy/usr/local/etc/havp/templates/en” “/usr/local/etc/havp/templates/en”

    Reboot and the modified file(s) appear. Obviously you have to copy all directory contents even if you’re only changing a single file as the whole directory gets re-mapped.

    As I said, a bit of a hack !


    The Soultion works great andy!, however the mount command that was issued is lost after reboot


    Clifford Dsouza


    Yes very awesomely done. havent tried the reboot thingy, but as my uptime usually stands around 150+ days im not worried about it yet.

    i simplified ur routine a bit, i copied the blacklist.html to my /Database/me/ folder then did “mount –bind /Database/me/blacklist.html /usr/local/etc/havp/templates/en/blacklist.html” and it works, ive changed all my colours and text.

    what i would like to do tho, is add my own images to the page. i have made a folder in my /Database/me folder and deposited the image there, now i can link to http://websites/image.jpg but for some reason cannot link to a local image. any ideas where else it should go, or the right way to link a local image?

    this was great when i started usin it, it just keeps getting better.


    edit: to make ur –bind stick, add it to the “post boot script” in the startup/cron tab

Viewing 8 posts - 1 through 8 (of 8 total)
  • You must be logged in to reply to this topic.