Danguarding – editing configs with VI breaks something….

Forums Network Management ZeroShell Danguarding – editing configs with VI breaks something….

  • This topic is empty.
Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #41311


    I’ve been trying to implement Dansguardian on Zeroshell for serveral hours. I notice that every time I edit one of the configuration files for Dansguardian and reboot the system, it will report a problem connecting the parent proxy server. This corresponds with no content filtering, though everything else appears to work.

    I have been trying to edit the files using VI / VIM at the location:

    I have unsuccessfully tried:

    I have even tried backing up one of the files and editing the original. After failure for the program to boot, I can not even copy the backup back to get it working again.

    So far, my only soution has been to re-run the ‘install.sh’ script again, which repairs it back to the default configuration.

    Anyone have any idea what I am doing wrong with this? It would appear that any changes to the files cause Dansguarding not to fully boot.

    Note that I’ve tried as little as just changing the blocked timeout from ‘0’ to ‘300’ in the main config. I’ve also added a single new-line with a blocked site address to the bannedsitelist.



    Error message I was getting was:
    Select: Error connecting to parent proxy
    -m iprange –src-range

    I finally figured it out. I had followed instructions to alter the settings of HAVP and placed an older config file in the /Database directory. I wasn’t picking up the new settings that the DansGuardian script had placed in the file.

    I removed my updates to the HAVP script from the [Startup][Preboot] section and it now works with the config changes to DansGuardian.

    Sorry for the errant failure post – guess making configuration changes at 3:00am on little sleep doesn’t work.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.