Download files issue when enable Netbalancer

Forums Network Management ZeroShell Download files issue when enable Netbalancer

  • This topic is empty.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #41906

    Dear Guys

    I have a problem and need your help.
    I just noticed that whenever i turned on Netbalancer , i faced a download file problem.

    My Scenario (For example):
    My zeroshell has 2 physical interfaces
    One interface (ETH00) connect to LAN and another (ETH01) connect to internet .

    For Load Balance purpose:

    I added ip alias to ETH01 so that ETH01 has 2 ip address i.e.
    ETH01:00 =
    ETH01:01 =

    I connected ETH01 to two Gateways (ADSL Router) via switching hub.
    GW1 =
    GW2 =

    Please see image below for network diagram

    Then i configured Zeroshell to use Netbalancer (Load balance and failover)
    to these two GW.

    The problem is that whenever i enabled Netbalancer on these two GW ,
    i couldn’t successfull download a file . When i started download ,i could
    download only few minutes and then dead. However if i used only one
    GW, i could download successfull everytime.

    * I’m quite sure that the problem caused by the outside servers confused
    about the ip address (GW1 or GW2) that connect to them i.e.
    When i started download the file , Zeroshell used GW1 connect to the outside
    server however after few minutes Zeroshell used GW2 connect to the
    server. *

    *Are there any solutions to lock state i.e. force Zeroshell to use only one
    GW (either GW1 or GW2 ) until download complete *

    Thanks in advance

    Best Regards


    If you set weight to 99 you can minized this problem.



    There is already a discussion about this problem in the forum.
    A quick resolution would be to apply netbalancing rules according to the source IP. For example if the source is coming from ETH00 and is use GW1 otherwise if it is use GW2.


    Thank you so much for your advice

    Best Regards

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.