First contact with zeroshell

Forums Network Management ZeroShell First contact with zeroshell

  • This topic is empty.
Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #42730


    I was a proud owner of a “la fonera 2N” Router (, but I realized my home infrastructure was getting too big and too splited (router, external disks, NAS, SIP box, etc.), so I decided to sell it to invest in a new stand-alone server that could integrate all the functionality in one single box, and with a better performance (and lower power consumption). The idea was creating a linux server that could act as a router (wireless and wireline) and firewall, as well as a NAS (SMB, NFS, and FTP), webserver, SIP proxy (asterisk), and (why not?) bitorrent/rapidshare client. After some investigation I found this zeroshell distro that seemed an excelent starting point. The concept itself is great, and it’s good for people that don’t want (or don’t know how) to use the shell. It seems a very decent distro with strong security options, which is good for my purpose. I’m completely aware that these add-ons (FTP, NFS, Asterisk, bitorrent, etc.) will not appear in the zershell webinterface, and I’m OK with that, since I’m used to manage these kind of things via command line. However, I’m having a really hard time to install anything else in the system:

    Firstly, my AR5008 Atheros Wireless Network Adapter is not recognised… Seems I have to recompile the kernel
    Secondly, I tried to install SMB as stated in “” and it failed. (I just realised there is a workaround, I’ll try it)
    Thirdly, I tried to install a FTP server. The suggestion in “” doesn’t work because apt-get is not installed zeroshell. I tried to compile the source code, but there is no gcc compiler in the system…
    Then, I tried to install a gcc compiler but also without sucess…

    So, I have an excelent sytem (for the purpose of a router), an excelent distro, but I can’t even start using it because I’m not able to customise it in my way. As you can imagine, I’m getting a bit frustrated, and I get even more frusrated when I boot the system with a pendrive linux (Kunbutu) and everything works like magic (wi-fi, installation of sw, etc.)… However, I’d like to keep zeroshell because I believe it would be better fited to my purpose.

    I’m sure the problem here may be related with my lack of experience in programing and in compiling code, even with Makefiles. I do have good experience in Unix/Linux administration (configuration and troubleshooting), but these compiling options always made me crazy…

    So, is there anyone that could give me some hints about how to add sw to the zeroshell system? And how to get the wifi card working?

    By the way, my hardware is the following:
    – JetWay JNF95A-270-LF Intel Atom Mini ITX Motherboard (atom 1.6GHz, 1GB RAM, HDD WDGreen w/ 2TB, GB ethernet)
    – Realtek RTL-8139/8139C/8139C+PCI NIC
    – AR5008 Atheros Wireless Network Adapter Mini-PCI Express

    Thank you,
    Joao Silva


    Hi jabss!
    Almost all the answers you need can be found here: (start with “Building packages from source by abbra kadabra (vpn_rollercoaster)” ).

    There is another great OS for routers and embed systems that you should look at: OpenWRT. All the apps that you need are available via packet manager (opkg).

    If you have problems with the the samba fix, let me know.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.