HELP problems booting from USB stick

Forums Network Management ZeroShell HELP problems booting from USB stick

  • This topic is empty.
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #42638

    I put the ZeroShell-1.0.beta13-CompactFlash-IDE-USB-SATA-1GB.img on a USB thumb drive using win32diskimager-RELEASE-0.2-r23-win32 on my Win7 PC. Then I plugged the USB thumb drive into a VIA ART-3000 unit with (blank) CF and no other drives and tried to boot it off the thumb drive.

    This does not seem to be recognized by the BIOS as a bootable image. I do not even get to a GRUB prompt or anything, the BIOS just reports that it can not find a bootable disk.

    In the BIOS, under “Integrated Peripherals” – “USB Device Setting” everything is enabled and the drive shows up as “USB DISK 2.0 PMAP”.
    I have tried this with the device set to all of “FDD mode”, “HDD mode” and “Auto” with no change in result.

    Under “Advanced BIOS Features” the boot order is…
    1st “USB-FDD”
    2nd “CDROM”
    3rd “Hard Disk”
    and “Boot Other Device” is enabled.

    So you can see I have confirmed that the BIOS sees the USB thumb drive (it is a plain valilla 1 GB thumb drive, I gave up trying this with a SanDisk USB thumb drive a while back). This makes me think the thumb drive hardware is not a problem, but not sure.

    I have also plugged the thumb drive into my Fedora PC and it recognizes all the contents of the drive (did not try to actually boot off it on that machine). There is a ext3 GRUB partition, an unknown-format CD partition, and an ext3 syslinux(?) partition. This makes me think the image was written to the thumb drive correctly.

    So, questions…
    1. Am I trying to do something with the image that it is not intended to do? Do I need another OS already on the system (ie on the flash card) to load this?
    2. Is there an issue with the image file booting from a USB stick?
    3. Is there some error in my device setup?



    You indicated that you have access to a linux system. You might want to try these commands from the linux system:

    gunzip ZeroShell-1.0.x-CompactFlash512.img.gz
    dd /dev/sdc

    (copy and pasted from this page: )

    make sure to change /dev/sdc to correspond to your usb thumb drive. If you aren’t sure which device it is, run this command before and after plugging it in and compare the differences:

    ls /dev | grep sd


    Yeah I can do that, but it is in a different location. As stated I can see the drive with the image from the Linux system using GParted etc and its looks okay. But I will try it out and see what happens.

    Also, as an update, I was able to boot FeatherLinux from the plain vanilla 1GB USB stick on this VIA ART-3000 box setting the USB as stated above to “FDD” (it still did not boot as HDD).

    I wrote FeatherLinux with the same Windows software that I used to write Zeroshell to the drive. But I have to say the contents looked quite different, no extra partitions and a FAT filesystem.

    So this seems to point back to that particular Zeroshell image ability to boot from USB?


    @jasonh100 wrote:

    try these commands from the linux system:
    gunzip ZeroShell-1.0.x-CompactFlash512.img.gz
    dd /dev/sdc

    That particular image is not on the download list but I used the most recent beta version ZeroShell-1.0.beta13-CompactFlash-IDE-USB-SATA-1GB.img.
    Using linux dd as quoted above (substituting the zeroshell image name) I wrote this image to the USB stick, the same stick that successfully booted on my VIA ART-3000 with FeatherLinux.
    I should also mention that I used gparted to delete all the partitions on the stick, leaving it completely unallocated, immediately prior to using dd. So I was starting with a fresh slate.
    Same result, the stick will not boot with that image. (BIOS reports no bootable media or something like that)

    Do I need to do something else to remove the partitions in the image to boot from USB, and if so how would I do that without destroying the contents? Just a wild guess. Any other ideas?


    That sounds weird, try to toggle the BOOT bit on the partition containing the /boot folder of the installation.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.