How to install on harddisk

Forums Network Management ZeroShell How to install on harddisk

  • This topic is empty.
Viewing 15 posts - 1 through 15 (of 20 total)
  • Author
  • #42490

    Hi @ll

    Where’s the trick to install ZS on harddisk ? I have tried doing this according to the manual of Christian Colombini but this does not work.
    I have even deleted all partitions from the disk and created new ones with
    gparted (boot, data and swap)
    I think the problem is that the disk is not made bootable but how can I do this ?

    Thank you for your hints in advance



    You can either copy it with

            gunzip ZeroShell-1.0.x-CompactFlash.gz
    dd /dev/sda


    gunzip -c zeroshell.img.gz>/dev/sda

    Both should work, no need to do anything on the disk beforehand.


    Thank you very much but whatever tip I have tried so far the box is refusing to boot.
    I have tried Win Image and Physdiskwrite as well as mentioned in other forum posts but I cannot boot from my S-ATA HDD.
    I am using a Intel Atom 330 box, 2 Nic’s, 2 Gig RAM and a 80 GByte
    samsung S-ATA HDD.

    I’ve been testing for 2 weeks but I’d like to use the Proxy feature and so a HDD install is much better I guess


    Proxy feature is not caching something on the disk. You can always run from the CD and use the hard disk to store the profiles and the logs.
    I don’t think that I have ever tried with windows tools, so I strongly suggest using a linux live cd to copy the file on the HDD with one of the above commands.


    Thank you but yes, I have tried the live CD and the procedure described many times in the manuals but the box is refusing to boot.
    In order to exclude that there is something wrong with the HDD I have even changed it and I even wiped the original one using Dban to start from the scratch.
    I get absolutely no error messages during the copy/install process and
    as soon as I reboot it does not work any more. I mean the box tries to
    boot from CD which I have removed according to the manual, then from LAN and then… nothing
    Maybe this is related to my hardware ?


    In the BIOS I hope you have enabled the hard disk to be able to boot.


    I could not install the beta13 release hard disk, I get error on boot, I did months ago with the release beta12 and it worked well .. someone can tell me q’s on?


    Yes of course, the HDD is enabled and configured to boot first


    If it doesn’t even show the grub screen, then for some reason the disk doesn’t seem to be written correctly. If you see error after the grub, maybe the sata controller is not supported in the kernel.
    I haven’t tried beta13 yet (nor will I until August with my tight schedule) so I don’t know if it is a problem of the specific image.


    must be because the beta12 worked perfectly


    My computer would start booting off the hard drive, then couldn’t find the drive to continue booting after the initial boot messages displayed.

    ( I posted this in 2008.)

    I had trouble booting the SATA drive on my 1U server. I tried a lot of CMOS settings for the drive and other hardware configs and nothing fixed it.

    Finally, moving the drive to SATA channel 2 instead of 1 allowed it to boot as if it was an ATA drive. That works.


    In my case I had to manually add the sata driver to the cdrom so it was able to recognize the drive.
    Basically I had to unpack initrd and add this driver. I looked the details somewhere on the forum.

    cp ahci.ko_2.6.25.20 /tmp/initrdFolder/lib/sata/chipsets/ahci.ko


    I am having the same problem after writing the image to the hard drive.
    I get to see only: ‘grub’ (without the quotes) at the upper left corner and nothing more. It just stay there.


    I have the same problem. After instalation and restarting I have:
    Grub error 17


    [Problem soleved]
    I tried again but this time following Cristian Colombini instructions at
    The only different this time is that I followed the exact instructions:

    root@zeroshell root> cd /mnt/
    root@zeroshell mnt> mkdir chiavetta
    root@zeroshell mnt> ls
    chiavetta loop1
    root@zeroshell mnt>

    root@zeroshell mnt> cd /
    root@zeroshell /> mount /dev/sda1 /mnt/chiavetta
    root@zeroshell />

    and then:

    root@zeroshell /> cd /mnt/chiavetta
    root@zeroshell chiavetta>

    root@zeroshell chiavetta> gunzip -c zeroshell.img.gz>/dev/hda

    instead of using the /mnt/loop1 as in the other instructions

    Wish I knew what was the problem. I am not good in Italian but may be chiavetta made the trick:-)

Viewing 15 posts - 1 through 15 (of 20 total)
  • You must be logged in to reply to this topic.