[Howto] How to install on USB flash guide: Windows

Forums Network Management ZeroShell [Howto] How to install on USB flash guide: Windows

  • This topic is empty.
Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
  • #41859

    Holy crap this took me forever to figure out. Taking hourly wage times number of hours to figure out and a new hardware router would have been cheaper, but oh well. Hope this helps someone. Please post if it does.

    I tried various combinations of Windows based software to write ZeroShell-1.0.beta12-CompactFlash-IDE-USB-SATA-1GB.img file (extracted from the gz file) and ZeroShell-1.0.beta12-CompactFlash-IDE-USB-SATA-1GB.img.gz to two different USB drives (2GB and 4GB).

    Here are the tools I used
    * physdiskwrite (winner)
    * flashnul (kept crashing)
    * dd for Windows (grub errors)
    * unetbootin (did not write anything)

    Procedures I ended up doing that worked:
    1. CRUCIAL: Clear all partitions on the USB thumb drive so that it’s all RAW
    2. Extract the desired Zeroshell build .img file from the .gz file
    3. Run (I used Windows 7 RC running CMD as Administrator):
    physdiskwrite -u [name of the .img file]
    4. You’ll be presented with list of drives on your system, and asked to type the number of the drive representing the USB thumb drive. Type the number appropriate for your system
    5. You’ll see a counter showing byteswritten/bytestotal start incrementing. When it stops, you’re done.

    DD might have worked if I deleted all the partitions and tried again, but at this point, I’ve thrown a lot of hours at it and need to move on.


    At least in linux, dd should work no matter if you clean or not the destination disk, because it writes bit by bit all the disk, altough dd in windows is not the same as in linux.
    Another suggestion, could you edit your post and add [Howto] in the subject? People looking for this will find it easily.



    I am unable to get this to work. I followed the instructions a good few times – but when I try to boot off the drive my PC does not recognise the USB stick as a bootable device. I can get the same PC to boot off the same USB drive for other distributions.

    Any idea what may be going wrong?



    Maybe you need to enable the BOOT flag on the USB stick’s partition.


    @ppalias wrote:

    Maybe you need to enable the BOOT flag on the USB stick’s partition.

    Any idea how to do that?


    I am certainly no Linux expert (hence the Windows writeup), but are you positive that the memory stick was raw first? The behavior you describe is exactly what I remember if the stick already had a partition on it first. To be honest, I can’t remember what software I used to check and delete any partitions, but it could well have just been Windows disk management (right click my computer and select manage, then look for the disk management section). Delete any and all partitions so it is all unused, then try again.


    I figured out how to do it (this is on Win7). I followed raftech instructions, but also had to do the following after:
    1) Run diskpart then type:
    2) select disk
    (where is the disk number as shown in disk management)
    3) detail disk
    (just to check you have selected the right disk)
    4) list volume
    (Have a look for the 13mb volume – on a removable disk)
    5) select volume
    (where volume number is the number as found in 4)
    6) active
    (this step makes the stick bootable)

    It should now boot. Be careful – you can do serious damage to your Windows install if you make a mistake…


    Hey, what’s up here? I tried to post something before and my post never showed up.
    If it’s not just all bots here, let me know. I’m looking to network
    Leave me a post and introduce yourself


    Here is a howto for installing Zeroshell in Windows [ With screen shots] http://www.computing-tips.net/Solution_Howto_install_Zeroshell_Hard_drive_WinXP/

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.