Install to HDD fail. Bad block device?

Forums Network Management ZeroShell Install to HDD fail. Bad block device?

  • This topic is empty.
Viewing 9 posts - 1 through 9 (of 9 total)
  • Author
  • #41983

    I’ve tried installing zeroshell, following the PDF on the homepage (basically: gunzip the image file and it will create partitions etc for you). This does not seem to work for me.

    The file unzips without errors, and three partitions are made. However I cannot mount any of these partitions, it says “bad block device”.

    Strange, but I reboot anyway. The bootloader seems OK, it reads the kernel but then fail on mounting the root filesystem. It just keeps trying to probe the root filesystem (nine times, then I get kernel panic: Unable to mount root fs on unknown-block(1,2)).

    I’ve tried this with beta12 on a virtual machine in an ESX environment. Booting of the live CD works fine.

    Any ideas?

    EDIT: I tried toggling the bootable flag – it makes no difference.


    Which command have you used to gunzip and copy?

    gunzip  /dev/hda

    did you gunzip it first and then copied it with dd?

    gunzip -c zeroshell.img.gz>/dev/sda

    (Following to the PDF)

    Btw, the image file is not mountable on loopback either. But maybe it should not be? (

    mount -o loop image.img 


    I’ve md5sum’ed the image and it’s correct.

    I’m guessing this is a vmware ESX-thing or there is an error in the image file. Has anyone installed the beta12 image this way successfully? I’ll try on a physical machine this weekend, but it would be nice to hear from anyone who succeeded. If that works and we figure out the ESX problem you could do a ESX appliance version as well.


    I suppose you have downloaded the correct image meant for VMware.
    I have tried twice to copy the image to a disk with the command
    gunzip -c zeroshell.img.gz>/dev/sda
    and works fine both on beta11 and beta12.


    i Have the same problem install into a new HDD, i install the usB,IDe,SATA beta 12 version and put the bootable flag in 1, but it didn’t made a diference, i got the same kernel panic error, does someone have a idea? i have been trying for a lot of days without any result.

    PLEASE HELP ME!!!!!!


    Same here, still looking for an explanation …


    Finally found the solution in some thread i don’t recall. The solution is easy once you’ve got it.
    Basically the initrd created for your image doesn’t have the drivers you need for sata, so you have to copy them from the iso.

    This steps should work:
    #Plug you disk
    mount /dev/sdb1 /tmp/image
    gunzip -c /tmp/image/initrd.gz > /tmp/initrd.unzip
    mount -t auto -o loop /tmp/initrd.unzip /tmp/initrdFolder

    #Mount the iso downloaded from the website
    mount -o loop /tmp/ZeroShell-1.0.beta12.iso /tmp/image2
    find /tmp/image2 -name “ahci.ko”

    #Copy the ahci.ko file into the right place
    cp ahci.ko /tmp/initrdFolder/lib/sata/chipsets/ahci.ko

    #Remount the system
    umount /tmp/initrdFolder/
    gzip -c /tmp/initrd.unzip > /tmp/image/initrd.gz
    umount /tmp/image

    After this it should work fine. It does for me at least


    OK so I noticed that there is some confusion when people install the IDE CF ver. of ZeroShell. I have found the easiest way to get it up and running in VMWare ESXi4 is to just make the disk IDE instead of SATA from the begining.

    Here is a tutorial I use when setting it up…
    Make ZeroShell Appliance in VMWare ESXi4

    Make a 2GB disk in vmware
    NOTE: Make the 2GB drive IDE and skip copying sata drivers over!!!

    Edit your machine to boot off ubuntu desktop live cd & give it 512 ram to start (you have to have the iso in you data center, use Fast-SCP by Veeam to transfer iso – google it)

    format disk ext3 with sudo gparted inside Ubuntu Desktop (It’s a Gnome GUI but start it from root command line)

    Goto – Applications / Accessories / Terminal
    sudo gparted

    Next mkdir and mount disk
    mkdir /mnt/sda1 ; mount /dev/sda1 /mnt/sda1

    Download the IDE Sata USB zeroshell.img.gz from Ubuntu will auto download the file to /home/ubuntu/Downloads

    Write the zeroshell image to sda1
    gunzip -c /home/ubuntu/Downloads/Zero*.img.gz>/dev/sda

    You might have to use the full name of the zeroshell file, but notice that you write it to sda and not sda1!

    Shutdown the system
    shutdown -P now
    or click the shutdown button in the Ubuntu GUI

    Edit machime
    256 Ram
    remove cd-rom

    Should now boot ZeroShell with no extra editing.

    Make backups as you go in-case you foobar something. There is no reset to factory defaults button!!

    Hope This Helps



    Hi, this probably works with vmware, but in phisical hardware, sometimes the IDE emulation stuff doesn’t work as it should sometimes, mainly the order of the devices may get screwed.
    So if anyone needs sata, you’ll have to use the ahci.ko patch

Viewing 9 posts - 1 through 9 (of 9 total)
  • You must be logged in to reply to this topic.