Installation on a net4801

Forums Network Management Embedded Devices Installation on a net4801

  • This topic is empty.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #40570

    Not having a good day. Looks like I wasted a lot of cash today for no good reason…

    First, I tried using Physdiskwrite on Windows to write the image to a CF card with a built-in CF writer I have on a Compaq PC. I put it in the net4801 and it didn’t seem to do very much…

    Since I didn’t have a console connection, I went out to grab some parts. First, I picked up a USB/CF Writer for my Mac.. I also grabbed a USB/Serial cable and a couple of gender changers since I the USB/Serial wouldn’t plug directly into the net4801.

    When I got home, I started a dd to write the image to my 512 Meg CF card on my Mac. Took about an hour and half I think (USB 1.1)

    Of course, the lugs for the gender changer match up exactly with studs on the USB/Serial adapter so you can’t attach them directly to each other, and they can’t be removed, so I had to disassemble the USB/Serial adapter to cut the lugs out. Removed the lugs from the net4801, attached it all together… Nothing on the console…

    To make a long story shorter, I still don’t have a clue what happens when it tries to boot up, as this cable doesn’t work on either my Mac or another Windows box… I can say (from the light activity on the net4801 at boot up) that it seemed to do the same thing with the CF card written in the Windows machine and the Mac. (Only hits the disk for a second or two, like twice.. Then just sits there. By comparison, a Monowall image hits the disk for about 10-15 seconds or so after the error light goes out..)

    Anyhow, not sure what’s wrong yet..


    Well, I’ve tried reloading the image several times via my Mac using dd.. So far, I can’t get it to boot in my net4801. I still don’t have a good console cable… It seems no one carries regular old run of the mill serial cables anymore…

    I just need a good gender changer now, I believe. (I broke my old one in an attempt to get it to work with the cable I had.)


    Starting from the release 1.0.beta3 the boot process messages are not longer redirected to the serial console using the standard compactflash image and the serial console speed is of 38400bps instead of 19200bps.
    If you want the redirection of the booting process takes place you could use the WRAP version of the compactflash. I should work fine on the Soekris 4801 too.



    One little detail can cause hours of frustration…

    One needs a Null Modem adapter, which I didn’t have, to see the console on these… Now that I have that, I think I see where my problem is.

    The net4801 I wanted to try out had an Intel 1000 GT card in it. By looking at the output of ifconfig, I can see that this was the adapter it had selected to be ETH00. The problem was that it didn’t appear to be seeing any traffic. (No packets were incrementing, even though I was continuously pinging it.) When I moved the CAT5 cable to the other ports, I could see that the packets were incrementing, so I can only guess that ZeroShell doesn’t support that card yet, fully.

    No problem, I figured.. I just removed the Intel NIC and rebooted. This time, it completed booting, but my pings still failed. Now, an ifconfig command shows only ETH01, 02, and 03. No ETH00.. Then, I remembered reading about a feature that remembers what hardware was used for a particular interface, I believe.. So, I’m re-writing the image now and should have my Soekris up and running instead of a VM soon.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.