installing on flash disk with linitx device

Forums Network Management ZeroShell installing on flash disk with linitx device

  • This topic is empty.
Viewing 10 posts - 1 through 10 (of 10 total)
  • Author
  • #40766


    I have a few linitx machines here, equiped with IPcop and wanted to replace this for zeroshell.

    I use a 4 Gb flash disk with the .beta6 img.gz unzipped straight to the device. Partition table comes up nice, the kernel recognises the disk at boot time. It is on ‘hdc’, and I can’t swap ATA controllers.

    Nevertheless, After booting the kernel it gives ‘cannot mount root; tried ext2, ext3,…’ and panics.

    Any suggestions for boot param’s? (tried the same as Ip cop gives; tried some acpi variants, and passing root=/dev/hdc1, but no succes)

    is root /dev/hdc1? I suppose it isn’t; since it is a compressed image? Sorry I get a bit confused on the zeroshell layout..

    Thanks in advance,


    Zeroshell’s CompactFlash must be connected to the Primary Master IDE connector. I’d like to support LinITX hardware but I have not it to test.



    ok, “solved” the problem.

    I created an extended partition after the normal hdc1,2,3, so hdc5, formatted it in ext3; and then gunzipped the rootfs and copied all data from a mounted rootfs, and the /usr, /sbin, /lib/modules directory from the ‘virtual cdrom’ device, in my case hdc2 to the newly created /dev/hdc5.
    Then I appended a root=/dev/hdc5 to the menu.1st of the grub-config.

    In fact I could wipe out all the mounting in the ramdisk thingies in the linuxrc file from the initrd.gz, but I can live with the complaints, then I realise what I’ve done setting this up today when it reboots 🙂

    Works perfectly thank you!

    For more details; ask!


    Is all the rest of the hardware correctly recognized?
    How many network interfaces are recognized?
    Could you perform a performance test about the network interfaces?
    I like LinITX devices and I’d like to support them.

    Regards and thank you in advance for your answers.


    The device I installed was a LinITX LEX TWISTER CV863A (1Ghz Fanless) – 4 NIC + 2 PCMCIA.

    The four nic’s come up properly:

    eth0: RealTek RTL8139 at 0xf881c000, 00:40:48:b1:01:3c, IRQ 11
    eth0: Identified 8139 chip type ‘RTL-8100B/8139D’
    ACPI: PCI Interrupt 0000:00:09.0[A] -> Link [LNKB] -> GSI 10 (level, low) -> IRQ 10
    eth1: RealTek RTL8139 at 0xf8832000, 00:40:48:b1:01:3b, IRQ 10
    eth1: Identified 8139 chip type ‘RTL-8100B/8139D’
    ACPI: PCI Interrupt 0000:00:0a.0[A] -> Link [LNKC] -> GSI 11 (level, low) -> IRQ 11
    eth2: RealTek RTL8139 at 0xf8834000, 00:40:48:b1:01:3a, IRQ 11
    eth2: Identified 8139 chip type ‘RTL-8100B/8139D’
    ACPI: PCI Interrupt 0000:00:0b.0[A] -> Link [LNKD] -> GSI 11 (level, low) -> IRQ 11
    eth3: RealTek RTL8139 at 0xf8836000, 00:40:48:b1:01:39, IRQ 11
    eth3: Identified 8139 chip type ‘RTL-8100B/8139D’

    I have a FX5620 VIA EDEN 1Ghz 6 NIC Firewall/Router Platform – 1xGigaLAN + 5×10/100 system about to test with zeroshell…

    How would you like the performance test of the network interfaces?



    I have installed the fx5620 linitx with the 6 nic’s on the same way:

    For the 512 Meg flash disk, I couldn’t create an extended device big enough, there was only 11 meg free after the normal Zeroshell beta6 install.

    (I took out the 512 Meg flash disk and inserted this in an usb flash card reader; so it comes up on my machine as /dev/sdd, but for convinience i’ll call it /dev/hdx, since it comes up as an hd device on the linitx box)

    1. I copied the files from /dev/hdx2 (the cdrom device) to /dev/hdx3 (the DB device),

    1.1 I created via fdisk an extended partition, /dev/hdx5 (the 11 meg that was left) and copied the _DB… file from the original /dev/hdx3 to the newly created hdx5….

    2. and the files (EXCEPT the symbolic links /usr en /sbin) from a

    mount -o loop /mnt/hdx2/isolinux/rootfs /mnt/zeroshell-root

    (where /mnt/hdx2 is the mounted cdrom/iso9660 partition of the flash disk, and the /mnt/zeroshell-root is just a testing/tmp directory) to the /dev/hdx3.

    3. Fixed the symbolic link in /lib/ named ‘modules’ (orig. pointed to /cdrom/modules) to point to ../modules (the copy in 1.)

    4. edited /mnt/hdx1/grub/menu.1st and changed

    kernel /vmlinuz ramdisk_size=131072 quiet


    kernel /vmlinuz ramdisk_size=131072 ide=nodma root/dev/hdc3

    5. could remove the cdrom thingies in /mnt/hdx1/initrd.gz:
    copy it to a tmp directory;
    unzip it (gunzip initrd.gz)
    mount it (mount -o loop initrd init-mount)
    edit the linuxrc file in the init -mount root-directory:
    remove/comment everything except the

    mount -t proc proc /proc

    Ok, everything booted fine as well, but when it starts searching for a DB, he finds it at /dev/hdc5, but returned a FAILED… Nevertheless, everything seems to work, network interfaces come up all six, and the webpage shows up.

    Is there anything wrong with the DB database tmp – dir being 11 meg instead of 300 meg?

    all 6 interfaces come up nice:

    eth0: RTL8169s/8110s at 0xd080ca00, 00:04:a7:05:c0:91, IRQ 11
    eth1: RealTek RTL8139 at 0xd081ef00, 00:04:a7:08:67:85, IRQ 10
    eth1: Identified 8139 chip type 'RTL-8100B/8139D'
    eth2: RealTek RTL8139 at 0xd0820e00, 00:04:a7:08:67:84, IRQ 11
    eth2: Identified 8139 chip type 'RTL-8100B/8139D'
    eth3: RealTek RTL8139 at 0xd0822d00, 00:04:a7:08:67:83, IRQ 9
    eth3: Identified 8139 chip type 'RTL-8100B/8139D'
    eth4: RealTek RTL8139 at 0xd0824c00, 00:04:a7:08:67:82, IRQ 5
    eth4: Identified 8139 chip type 'RTL-8100B/8139D'
    eth5: RealTek RTL8139 at 0xd0828b00, 00:04:a7:08:67:81, IRQ 10
    eth5: Identified 8139 chip type 'RTL-8100B/8139D'

    except the numbering on the device is reverse. (on the device is written above the networkports 1,2,3,4,5,6, and 6=ETH00, 5=ETH01,… ), nothing to bother about.



    I’m search for way to install zeroshell on USB stick, and found this topic
    I dont have deep knowleadge in booting glinux, only as a user of ready products.
    But if there a way to change booting todevhdc5, is there way to change to devsda1?


    I am very eager to test on the FX5620 platform and have been considering buying some samples. Before I do I was wondering if you have any feedback on how well the hardware performs? After the patches did you have any issues with the NIC?


    Hello Glesov;

    Of course you can change it to sda1… I would just create another partition where I would copy the rootfs contents in; (from the rootfs file (which is gzipped) and the sda2 (in your case), which contains the /sbin, /modules > /lib/modules and … m… /usr I think (I just halted my zeroshell device don’t know yet)..

    And Tucker: Just as it is; it seems to perform well in a medium-load environment, with the 6 nic’s on the one LINITX device, and the 4 nics on the other device (forgot about the names – see previous post)

    I have just a small problem – not hardware related though. It’s just a pitty because it’s aim is to replace an old cisco pix: it doesn’t support multiple NAT – which the PIX does, to manage multiple IP adresses to be distributed from the PIX to some LAN – machines doing some webserving, tunnel-services or smtp receiving,…

    Well, of course it supports multiple NAT – hey – it’s linux so drop some extra iptable-rules in the boot scripts and you’re done. It’s just lovely to have it in an interface, so I don’t have to search for it after five years – when this ZeroShell story is long gone and forgot in a corner doin’ a hell of a lot things…


    Thanks for feedback on the linitx device … i will go ahead and get one for some testing.

    The multiNAT is as you say quite easy to do on iptables. I have implemented a form of netbalance in iptables. However I agree that is much better to have it in the UI and the UI on ZS is very good indeed … I guess MultiNAT could be easily added in.

Viewing 10 posts - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.