Is this configuration possible ?

Forums Network Management ZeroShell Is this configuration possible ?

  • This topic is empty.
Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #41455

    Hello !

    I have a little question about the configuration of the bridge between the VPN and the ethernet interface.

    I’ve tried to install ZeroShell on a virtual machine.

    I have put the virtual machine in the DMZ so it can be accessed trough internet, and that work perfectly
    I’ve used the default configuration and the VPN connexion work without problem (my remote clients get an IP 192.168.254.x).

    The problem is this : my remotes clients cant communicate with the LAN.
    In the tutorial for setting up the vpn server, it says :

    When OpenVPN is configured to use the TAP devices (that are software Ethernet Interface), it encapsulates Ethernet frames in the SSL encrypted tunnel. The advantage in the use of an Ethernet VPN is that, in addition to the routed mode in which the VPN gateway acts as a layer 3 router, it is possible to bridge the physical Ethernet Interfaces with the VPN ones. In this manner, not only the IP protocol can be sent across the VPN, but also other layer 3 protocols such as SPX/IPX NetWare, AppleTalk and NetBeui.
    Because in bridged mode, the Ethernet broadcast is also forwarded across the VPN, it is possible to use, for the remote VPN clients, the same DHCP server used for then LAN.

    I think that my problem is that my remotes clients dont have an ip provided by the local DHCP (192.168.1.x) so they cant communicate with the local computers.

    I’ve tried to create a bridge between VPN00 and ETH00 but I obtain an error (bridge not created…)

    So I just want to know how i can configure the VPN server to give a local IP adress to my remote clients.

    Here is a little example of my configuration :

    remote client
    Modem/router with DHCP Server (

    | | | |
    client1 client2 Server2k3 with VMWare

    Maybe this configuration is just impossible to use or I forgot something… (maybe it’s just because my ZeroShell is a client on the lan ?)
    Note : the virtual machine has its own IP on the lan and it can be contacted from the internet.

    PS : sorry for my english ^^’


    My bad problem solved !

    I just used the “Net” button near the remote client adresses configuration and added my internal network adress.

    Thanks a lot for your work & effort on this awesome distro Fluvio !
    Best regards,

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.