Issue with loading PHP plugin

Forums Network Management ZeroShell Issue with loading PHP plugin

  • This topic is empty.
Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #44876

    @peppe.chiapparo wrote:

    Dear Friends of ZS,

    I just installed ZS (Release 3.8.0 and I successfully tested the VLAN creation, the Failover over several connectivities, the Load Balancing on multiple communication channels and the Captive Portal thanks to the plugin ZeroTruth).
    But when I tried to add PHP pages into the ZS OS in order to send commands (call bash scripts via PHP pages) to satellite modems connected to the ZS but I was immediately blocked after I completed the PHP installation as plugin from the ZS repository. I tried to call phpinfo.php as suggested but i received the error 404 (page not found). Following various suggestions from this community I moved the file (phpinfo.php) to a reachable location but the result displayed on the browser is the following:
    phpinfo ();

    It means that the php module has not been loaded by apache2.
    I’m trying to figure out where to add the module and how to activate it but it would be easier (also because there is a trace that others can use) if you can explain how to manually add the php module to httpd.conf as in other distributions.

    Thanks in advance for your help and support



    The solution i found:

    Open /etc/httpd/conf/httpd.conf

    In the line position below the line (for those who have installed Zerotruth)
    Includes /DB/apache2/htdocs/zerotruth/conf/ssl.conf

    or if you do not have the Zerotruth plugin installed, the line position is before the line:

    Listen 8088

    Add the following line (after installing PHP, of course):

    Include /db/devel/mnt/var/register/system/AutoUpdate/pkgs/40800/pkg/httpd-php.conf

    Save and exit.
    Then restart the apache deamon:

    service httpd restart




    No help with PHP.

    But I recommend calling BASH srcipts from classic CGI instead of PHP. works fine for years already. Running another apache on separate TCP pot for that.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.