kernel upgrade?

Forums Network Management ZeroShell kernel upgrade?

  • This topic is empty.
Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
  • #41818

    Hi, I was wondering if it would be possible to upgrade the zeroshell kernel to >= 2.6.27. The reason I ask is because I’m looking to buy a WMIA-199N miniPCI card which uses the AR9160+9106 chipsets. I need ath9k to support them which comes packaged with >= 2.6.27 kernels.

    Is there any easy way to edit the CompactFlash image and repackage it with the newer kernel?


    Dear paperkut,

    Replacing the kernel involves a new kernel compilation of course but this also means modifying several places within the image.
    The first partition of the disk image contains grub boot parameters where new vmlinuz and initrd are to be replaced. Then the second partition holds a Z iso image where in the root directory, you will find once again the isolinux data with the vmlinuz and initrd files but also the modules and madwifi directories, which should be replaced as well.

    Although I have not tried replacing a kernel so far, from the development image I could give it a try.
    Best thing would be to have the choice within grub hence by just setting the default within the grub file (at hand), you will be able to choose.




    Thanks for your reply schoopy.

    Editing the grub files to point the new kernel wouldn’t be that big a problem I suppose. What I’m worried about is fulvio has probably applied alot of patches to the kernel in zeroshell, so alot of things might break if I replaced it with a vanilla kernel. Not to mention I don’t even know exactly myself how to compile a kernel properly.

    If you have the time, please give it a shot. I’d really appreciate it.



    I do not know about Fulvio’s patches to the kernel but we will also have to consider the modules that will be located on a kernel version path.
    Uname will allow us to do so but this implies modifications to the linuxrc script to account version.




    Hi schoopy, if you decide to give this a shot and have any luck, please let me know.


    Hi paperkut,

    As I am way to curious I give it a try and manage to have a build of the latest kernel booting.
    But, as there is always one, the issue is not in the modules and the need to rewrite the linuxrc file but rather within the initrd image.
    Indeed, Fulvio has put some modules directly in the initrd image for loop devices and USB/SATA drivers -> need to create a new initrd image as well.
    So I did and result is OK.

    OK this means we can do it but we really need to find a way for several users to simultaneously be able to bring updates or upgrades to Zeroshell without disk image, the first partition is not a problem on CF card though. But as you can see links are everywhere: initrd, rootfs, Z iso image.

    Fulvio, as everything is your great work, what would you suggest?




    Dear paperkut,

    Are you willing to test some upgrade procedure to modify your CF card and bring a new kernel along with a new CDROM Z iso in the second partition. Your configuration will remain (3rd partition).
    I do not have your Wifi card, at least not that I know of, and hence could not try myself.
    The procedure should work as the kernel is up running in my vmware image and the upgrade through a modified reboot as mentioned in has proved to work on my ALIX conf.

    All that would be required is a USB key to temporary hold the new data of the first and second CF card partition. Of course this assume that those have standard size, namely roughly 32MB for the boot partition and 150MB for the second.




    Dear All,

    You may try the following ISO CDROM image with the standard vmware image found in the Download section of Zeroshell webpage.

    Just replace within the vmware configuration to point to the new CDROM image.
    Upon booting the default is to run kernel However the old is also present and can be activated at boot prompt pushing option 1 or 2 (verbose).

    I have added ath9k and ath5k on top of the other madwifi stuff and also the VIA padlock. Note that within vmware it is of no use, I know!


    For the time being, my advise is not to try dumping this onto your CF card as I have not tried myself and am not sure about the size of the ISO. Once I tried, I will submit the procedure in order not to crash your system and remotely.



    Hi Scoopy,

    I am able to get the command prompt using VMWare with no problem but I can not access the web interface after the username and password are entered (blank screen). No problem if I use the original ISO image that comes with the VMware.

    I also burned the ZeroShell-1.0.beta12-dual-kernel to a CD and it is bootable but Kernel Panic in the end.



    Dear Andry

    you are right there is an issue with the image. As you mentioned once trying to log you get stuck with a blank page.
    I recreated a new image in place of the other (see above) while keeping the old rootfs instead of creating my own and it corrects the bug.
    For your information the rootfs was previously generated by some home made script which seems to miss something. I had done this as in any case I must correct the fstab inside. The reason for this is quite simple this comes from my development vmware image which uses an EXT2 file system as second partition not a ISOZ fs.

    Thanks for your remark.

    Hopefully this should now work.

    Concerning your kernel panic this might come from the iso image initially taken from the Compact flash pakage second partition.
    It might be that part is missing due to that. I should have a look at it.




    Dear Thierry,

    Thanks very much for your help.
    I finally have the chance to try it out and the CD-ROM booted perfectly.

    Thanks again,


    I just want to second the request for a kernel >= 2.6.27 with Athk9 support.

    I am planning to put a Wistron DNMA92 Atheros 802.11a/b/g/n miniPCI wireless card into my ALIX.3D3 system board to provide wireless N-network support. Would be great if this could become part of the next release!

    In the meantime I am going to try to put the ISO schoopy made on the CF card of my ALIX board and test it.




    I’m trying to put the ISO image back on an USB stick to be able to run it from stick on my netbook but with little luck, can anyone help me with this?

    I have placed a standard ZeroShell beta12 img on an USB stick and than used dd if=dual_kernel.iso of=/dev/sdb2 [options] to put the dual kernel version back on the stick.
    Then tried to boot the original kernel = working
    Altered grub.conf on the first partition to point to the extra 2.6.30 vmlinuz / initrd.gz files (which I copied from the iso image to the 14mb partition).
    But when I’m trying to boot the 2.6.30 kernel, the kernel keeps probing for a boot device and then ends with a kernel panic (unable to load rood fs). I assume this has something to do with the configuration of initrd/vmlinuz but that’s about where my linux knowledge ends.

    Suggestions would be very welcome!

    USB Stick contents:

    14mb partiotion with following changes:
    /2_6_30/vmlinuz (cp from iso image /2_6_30/)
    /2_6_30/initrd.gz (cp from iso image /2_6_30/)
    (both files have an extra menu option to point to kernel /2_6_30)
    /* (rest is unedited)

    CDROM partion with:
    /contents of dual_kernel iso from this thread

    cat grub.conf and menu.lst:
    title Kernel 2.6.30
    root (hd0,0)
    kernel /2_6_30/vmlinuz
    initrd /2_6_30/initrd.gz


    Hi all,

    I finally got time to test my solution on an ALIX board and indeed it crashes.
    I found out at least to mistakes so far.
    First the initrd.gz is a copy from the iso image and therefore only checks media type cdrom, which is not the case of CF card or harddisk.
    Therefore you never load from the disk the root partition.
    Second and worst, it seems I must have forgotten the iso9660 compressed file system within the kernel.
    So eventhough you correct first mistake you will be stuck by the second.
    I will supply a new version tomorrow and publish it online on my website at under the zeroshell structure.

    Sorry guys


Viewing 15 posts - 1 through 15 (of 15 total)
  • You must be logged in to reply to this topic.