Need help installing ZS3.0 on hard disk

Forums Network Management ZeroShell Need help installing ZS3.0 on hard disk

  • This topic is empty.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #43920

    Hi Guys,

    i try to install Zeroshell 3.0 on my harddisk using the live-CD and the 2GB Disk Image.

    I do it the following way:
    1. boot with live-cd
    2. format the disk with fdisk /dev/sda
    3. reboot
    4. make new filesystem on sda with mkfs /dev/sda
    5. sounting my usb-stick with mount /dev/sdb1 /mnt/loop1
    6. extract the 2GB-Disk-Image to the Disk gunzip Zeroshell… > /dev/sda
    7. wait until finished, reboot without live-cd

    now the problem:
    Grub can not read the filesystem an reports an error…

    I did the same way with ZS 2.0.RC3 and had no problem!
    Anybody has experience in installing ZS3.0 on harddisk?

    thanks in advance,


    As I understand there is Installation Manager now that can do it for you, but I built my own 3.0 HDD install by simply plugging the HDD into my other Linux machine and doing

    dd if=/path/to/ZS_flash_image of=/dev/sdb ibs=16MB obs=16MB

    where /dev/sdb was the ZS HDD device name. It worked fine.


    Thanks for your Reply.

    I tried your option, but grub reports the “unknown filesystem” error again…

    I don´t know where i am wrong in this case…


    Not trying to insult your intelligence, and I am sure you did, but did you unzip the flash image you’ve downloaded?

    For me the process was as follows:

    $ wget http://…/ZeroShell-3.0.0-Disk-2GB.img.gz
    $ gzip -d ZeroShell-3.0.0-Disk-2GB.img.gz
    $ dd if=ZeroShell-3.0.0-Disk-2GB.img of=/dev/sdX

    At first it did not work for me too, as I connected the external USB drive enclosure to a hub which was generating read/write errors. Once discovered that using checksum, I connected to the motherboard port directly, ran dd again and that time it worked.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.