Newbie to Linux and Zeroshell success story, kind of…

Forums Network Management ZeroShell Newbie to Linux and Zeroshell success story, kind of…

  • This topic is empty.
Viewing 1 post (of 1 total)
  • Author
  • #40875

    First off, I would like to say that Zeroshell does a great job as far as I can tell. The purpose of this post is for me to share my learning experience with others that are new to both linux and zeroshell. I am also kind of in a hurry while writing this so please ignore grammatical errors.

    I followed the HD install on the Documentation page and it didn’t work. I kept getting a GRUB command interface (not familiar with terminology so thats what I call it). I was able to install it into VMserver which I am new to also, and didn’t really understand how to make a transparent bridge which is completely necessary in my situation so I abandoned that So I did some investigation and modified the documentation page walkthrough and was able to successfully install to HD.

    With the HD install, this is what I did:
    I follow the steps except when I gunzipped, I gunzipped to a new directory I made on the USB drive. I created the directory in windows by making a new folder, so I cannot give you the specifics on how to do it in the CLI, but I would guess, go to the directory of the usb drive, the /mnt/yourname and mkdir name. I used the web GUI of zeroshell and deleted all partitions on my HD. I then followed a step at the bottom of the “How can I install Zeroshell” link on the “FAQ” page. the “dd

    After the successful HD install I totally configured it and backed up the database, I was able to successfully traffic shape (i think) in a lab environment. I then tried to install it into a spare server we have, it is actually not a spare, it is for another project but not in use yet. Anyways, I went to do the HD install on that and it didnt work, every time I got a kernel error thing — I am not really sure what the exact term was but I have seen it in these forums. I think it was because my HD was SATA though, I am not sure. We even tried to use the HD from the lab machine in the high powered server but it kept saying no boot device with many different BIOS settings. One setup that I thought would be for sure to work was to take the CDROM out of IDE1 and put the HD on that connection, the BIOS seen it as the 30GB HD but it still could find not bootable devices…

    So I am running it from the CD in a production environment and it is working good. I had to but my pre-configured database on the USB drive and activate it. The only thing is that my L7 protocols are outdated I think ( i do not know for sure ) and the P2P is not being filtered as well as I would like it to be. I can still download fast with P2P. I am not using the firewall just the QoS filter.

    ***** How can I update the L7 protocols running from live CD. The update instructions say to reboot, then I lose the Updated protocols.

    Another problem I have is with the administration. I think this is because I am not using the DMZ interface to manage the server — I am using a PC on the bridge, tried both sides, same problems. I will lose connection with the Zeroshell machine. I can’t ping it, can’t ssh into it, or https into it, but in a few minutes all is working well. It still works fine as far as passing internet, my bandwidth or ping times are not slowed down, I just can’t manage it. I do this mainly to view the logs and record IPs violating policy. But I can only view a few pages of logs then i lose connection.

    I studied the forums thouroughly and was able to piece together information contributed from other users. Thank you to the people that have helped me by contributing, your posts were very helpful.

Viewing 1 post (of 1 total)
  • You must be logged in to reply to this topic.