No Link Detected – Realtek

Forums Network Management ZeroShell No Link Detected – Realtek

  • This topic is empty.
Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #43279

    Hi guys – loving Zeroshell, recommended it for someone and now I’m stuck ๐Ÿ™

    Running beta 16 version of Zeroshell, now running from a USB stick (due to HDD install not working, I couldnt resolve the issue with it not seeing my SATA drive to boot from – it started to boot and then gives kernel panic after the ‘looking for USB devices to boot from – that’s another issue)

    I have got as far as booting to the main linux menu but I can’t get the box to talk on the network, can’t ping in or out.

    When I press N for show network interface, it tells me ETH00 status is No Link Detected. I’ve tried it connected via a switch, and direct with a crossover cable to my laptop.

    The hardware is an Acer Aspire Revo R3700 and the network controller is detected as a Realtek RTL8111/8168B.

    I did once have an issue running an Asterisk distribution with similar hardware, and found the resolution as detailed here;
    Not sure if it’s related or anything, but I couldn’t find Moprobe.conf in Zeroshell to change this.

    As an aside, I also couldn’t find any way to install Zeroshell on an already-running system, eg if I can get Centos running and happy, could I install Zeroshell as a ‘application’ rather than a ‘turnkey’ solution?



    I have the same problem with a realtek device not detecting a link. What’s weird is I can manually set it as up, see a link light, run tcpdump and see traffic.. but zeroshell says no link! I have not figured out how to get around this, fortunately the mini-itx machine I’m running has a 3 port gige daughter board I’m using.

    As far as installing to a harddrive, there’s a HOW-TO here:


    thanks but the hard disk routine is what i had already done. I get a screen full of
    Probing [1] USB and SATA devices to startup the system…
    Probing [2-9] USB and SATA…

    before getting
    Bootstrap failure
    Kernel Panic – not syncing : VFS: Unable to mount root fs on unknown-block(1,2)

    I looked into it but i was unable to resolve, even setting the disk to IDE mode in BIOS didn’t seem to help any.

    And it doesn’t matter for the system to boot from USB stick really, so long as the network works…

    I looked into compiling a driver but i got scared off with talk of developer images and such. Any more clues?

    with thanks and appreciation ๐Ÿ™‚


    I found the driver for realtek that resolves the problem with no link..

    The issue then becomes needing the kernel source and whatnot to compile the driver as a module. There’s a recent forum post of zeroshell r16 development image.. I think I’m going to write that to a usb stick, boot, and see if I can’t compile the module..


    It looks like the version uploaded here: uses the proper realtek driver. I just installed it and my realtek card works now.. yay.


    I think you guys should know, that R8169 driver in Linux is badly flawed.
    There are several problems with the driver that I am aware of.
    Of course there could be other problems that I did not face due to broad variety of possible chip revisions etc.

    1. The driver does not init the chip properly, specially after dual-boot into Windows (no link detected)
    2. Driver is not able to detect gigabit connection and falls back to 100 Mb
    3. For some weirdest reason actual xfer speed with Windows based hosts can be anywhere between 1 kB/s and 500 kB/s.

    I struggled with the last one and found that sometimes initiating a xfer with another non-Windows host may temporarily bring Windows host’s xfer rate to around 10 MB/s, but not all the time.

    I wrote to the driver authors and distro maintainers but they all gave me a runaround or did not respond at all.

    So R8169 is a bastard child of Realtek when it comes to Linux and the best solution is to replace it with 3com, Intel or another well supported chip.

Viewing 6 posts - 1 through 6 (of 6 total)
  • You must be logged in to reply to this topic.