NOIP and DUC software installation

Forums Network Management ZeroShell NOIP and DUC software installation

  • This topic is empty.
Viewing 4 posts - 1 through 4 (of 4 total)
  • Author
  • #44907

    Dear all,

    I’m using the managed DNS service from NOIP which require to run it’s own Dynamic Updater to use all the features of the service.

    TO do so it is required to download the file and compile using GCC libraries.

    Unfortunately when I run


    I receive this error

    gcc -Wall -g -Dlinux -DPREFIX="/usr/local" noip2.c -o noip2
    make: execvp: gcc: Permission denied
    Makefile:25: recipe for target 'noip2' failed
    make: *** [noip2] Error 127

    I’ve seen that in ZS the /usr/local is not writable nor by root but also if I change the destination path in makefile with by instance /root I receive the same error

    Is there anyone aware of how i can compile and install it?
    I also installed the development package with extra compiler hoping for th ebest but with no luck


    Steven Wittwer

    NOIP is built into ZeroShell. Just go to DNS|Dynamic DNS and enter the information. I use it as well, and it works great.


    ciao @ixalthim,

    are you using the ‘Managed DNS’ service from which include the registration of a domain or the standard/enhanced DDNS service?

    I can use the standard/enanched DDNS without problem. The further update gives extra possibility including the managment of 50 hosts possibly divided by group. Is the next level up and for this featurer the standard DDNS embedded in ZS works with limitations


    Steven Wittwer

    Ah. No, I am not using the managed services, just the free version of No-IP.

Viewing 4 posts - 1 through 4 (of 4 total)
  • You must be logged in to reply to this topic.