Odd CD-ROM behaviour

Forums Network Management ZeroShell Odd CD-ROM behaviour

  • This topic is empty.
Viewing 3 posts - 1 through 3 (of 3 total)
  • Author
  • #40771


    I’m trying out version 1.0b6 (first stab using Zeroshell) at the moment, and I’m seeing some odd behaviour.

    I’ve installed the flash image to a hard-disk and when I tried to start apache to start tinkering with the web management console, apache refuses to start. A quick check shows that many of the dynamic apache modules appear to be corrupt (file is all zeros, not ELF shared objects).

    So I figured I’d be clever and copy the files off the CD version. I headed over to /cdrom/usr…blah to see if the modules there were OK (note I downloaded the CD image and the flash ISO image separately). Interestingly enough the same files were corrupt. This is where the wierdness starts. I then realised that there was no CD in the tray at all.

    Regardless of whether or not I have a CD in the drive, or even a music CD, /cdrom is always mounted, and it’s contents are always the same. It’s a zeroshell CD, but….
    I’ve tried several reboots with or without the CD insterted, without the CD drive connected, with non zeroshell CD instered, but always the same results.

    Moreover, I’ve check the files on the actual CD in a different machine. The corrupted modules appear to be fine there.

    Anyone seen this before? Is this an issue in the flash image, a bad download (MD5 hash check seemed fine), or am I doing something totally boneheaded?

    Note: I am not so arrogant as to think that I have not done anything wrong. If this is something that I’ve messed up, please let me know.

    Thanks in advance.


    P.S. If anyone else has had issues with the Apache modules on the flash image as well, that’d be good to know about too ๐Ÿ˜‰



    Have you tryed to use memtest86 on your hardware?
    What I think is that your memory is not reliable.



    Thanks for the quick response Fulvio.

    I’m actually installing this inside a VMWare container running on my laptop (HP nx9040).
    The host OS (CentOS) is working fine, and the several other VMs I use on it, also have no issues either. This laptop regularly cops a beating running Oracle and as a Java dev box as well – with no ill effects (although it does slow down a bit ๐Ÿ˜‰

    However, just to be safe, I did run memtest along with a few disk checks as well – everything turned up clean.

    Just to be clear on this issue, I see the same behaviour across reboots of both the VM and the host OS – even full power-down and the system being off for a day. The behaviour is 100% consistant, so it’s unlikely to be memory.

    I shall keep digging at this end, and am happy to try and gather more info if you have suggestions.

    Thanks for the help so far, it’s much appreciated.


Viewing 3 posts - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.