Problem adding/modifying host from web interface

Forums Network Management ZeroShell Problem adding/modifying host from web interface

  • This topic is empty.
Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #41519

    I love zeroshell and I’m trying to put it in a more production use. However I’m running into this problem that I’m unable to successfully troubleshoot.

    I’m using the latest Zeroshell1.0 beta 11 ISO.

    This issue is when after I have created a new profile. Configured the REALM and LDAP correctly then reboot to activate the new profile. After reboot with the new profile, when trying to go to Network->Hosts and try to add a new host I get this message:

    Mar 06 20:13,56 ERROR: sh: line 1: 205: command not found while adding “,ou=Computers,dc=ucsd,dc=edu”

    However, when I’m running on a default profile that’s not saved to the disk, I have no problem performing that function. I’ve repeated this steps several times and nothing I have tried worked. Anyone is well come to duplicate this steps.

    My question is is there a way to do this task manually from the shell or some how one can assist me in figure out what generate that message and how I can fix it.



    Okay so I learned to turn on debugging form this post:

    It turned out, when the ldapadd/ldapmodify command when executed, issued a:

    Executing /usr/local/bin/ldapmodify -c -x -h -D”cn=Manager,dc=noc,dc=crbs,dc=ucsd,dc=edu” -w ‘mypassword’ /tmp/shell_o7748 2>/tmp/kerbynet.err.7748

    The ‘mypassword’ was instead pass on the command like as mypassword: ex:

    Executing /usr/local/bin/ldapmodify -c -x -h -D”cn=Manager,dc=noc,dc=crbs,dc=ucsd,dc=edu” -w mypassword /tmp/shell_o7748 2>/tmp/kerbynet.err.7748

    without any of the quotes, it does it properly with the quote for the simple password. So a complex password with semi-colon doesn’t get parse properly by the command line. I think this is a bug. Changed my password to something simple solved the problem.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.