Problem with Huawei E355 – not detected

Forums Network Management ZeroShell Problem with Huawei E355 – not detected

  • This topic is empty.
Viewing 1 post (of 1 total)
  • Author
  • #43660

    Hello everyone!

    I’m new to this forum so if I post in the wrong place or anything please correct me.

    I have a problem with a Huawei E355, Zeroshell does not detect the modem it in the web GUI.

    I read about usb_modeswitch and I have tried with the following:

    usb_modeswitch -v 0x12d1 -p 0x1c1e -V 0x12d1 -P 0x1506 -M “55534243123456780000000000000011062000000100000000000000000000” -n 1 -m 0x01

    This is the result:

    Looking for target devices …
    No devices in target mode or class found
    Looking for default devices …
    found matching product ID
    adding device
    Found device in default mode, class or configuration (1)
    Accessing device 008 on bus 002 …
    Getting the current device configuration …
    OK, got current device configuration (1)
    Using first interface: 0x00
    Using endpoints 0x01 (out) and 0x81 (in)
    Not a storage device, skipping SCSI inquiry

    USB description data (for identification)

    Manufacturer: HUAWEI
    Product: HUAWEI Mobile
    Serial No.: not provided

    Looking for active driver …
    No driver found. Either detached before or never attached
    Setting up communication with interface 0
    Using endpoint 0x01 for message sending …
    Trying to send message 1 to endpoint 0x01 …
    OK, message successfully sent
    Reading the response to message 1 (CSW) …
    Response reading got error -110
    Device is gone, skipping any further commands
    -> Run lsusb to note any changes. Bye.

    Result from lsusb:
    root@zeroshell root> lsusb
    Bus 001 Device 002: ID 0e0f:0003 VMware, Inc. Virtual Mouse
    Bus 001 Device 003: ID 0e0f:0002 VMware, Inc. Virtual USB Hub
    Bus 002 Device 008: ID 12d1:1c1e Huawei Technologies Co., Ltd.
    Bus 001 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    root@zeroshell root>

    As I understand it the product id 1c1e is still the same. The modem is also not visible in the web GUI.

    Any help would be greatly appreciated!!!!


Viewing 1 post (of 1 total)
  • You must be logged in to reply to this topic.