Problems with NAT and DHCP

Forums Network Management Networking Problems with NAT and DHCP

  • This topic is empty.
Viewing 2 posts - 1 through 2 (of 2 total)
  • Author
  • #42245


    I want to create WiFi in my school using ZeroShell. I set up the server, configured Captive Portal, but I have some problems with NAT & DHCP.

    Firstly, there is a sketch of my school network:

    As you can see, ZeroShell server is connected to the Internet via main server witch DHCP. I want to create subnet for WiFi (for example but there is one problem.
    At this moment, I created the bridge between ETH00 (to main server) and ETH01 (to ap) to test Captive Portal and it works correctly, but ZeroShell’s DHCP doesn’t work and computers, with are connected via AP gets IP from main server.

    I tried to create NAT. In router menu I set ETH00 as NAT enabled interface. After it, I enabled DHCP on ETH01 (, and created static route with destination

    When everything was done, I tried to connect to the Internet from my laptop. DHCP worked correctly, but when I opened browser, I saw nothing, even CaptivePortal login interface. When I tried to connect to the server via, CP arrived and I logged in. After it I was able to acces the ZeroShell web interface, but without connection to the Internet.

    Do you have any ideas why I wasn’t able to connect to the Internet? I was trying to create NAT according to this ZeroShell HOWTO


    Try to remove the bridge. Then remove the NAT, as my guess is that the main server is NATing traffic that goes to the internet.

Viewing 2 posts - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.