Question about the Router in Zeroshell

Forums Network Management Networking Question about the Router in Zeroshell

  • This topic is empty.
Viewing 7 posts - 1 through 7 (of 7 total)
  • Author
  • #41429

    I can’t seem to get the routing functions in Zeroshell to work correctly, so I think I must be overlooking something simple. Here is what I’m doing, I have Zeroshell installed on a computer with two network cards. One network card has IP address, the other The default gateway is, which is my router going to the internet. The router is connected to my zeroshell machine. My zeroshell machine can ping and trace out to the internet fine.

    I take a second computer with IP address and default gateway (the zeroshell box) and connect it to the zeroshell machine. This computer can not get to the internet and can not ping, it however, can ping (the zeroshell box). Also, it can not get out to the internet. can not ping, but can ping (zeroshell box).

    This makes no sense to me, a routers purpose in life is to connect two subnets, but this doesn’t seem to be working at all. Please someone explain to me what I’m doing wrong. Thanks.


    You have 3 possibilities to get the routing process to work correctly:

    1) Add a static route to the Internet router to tell it to use the router to reach the subnet;

    2) Enable RIP version 2 to both the routers so the routing is dynamically configured;

    3) Enable the NAT for the interface thatr has IP (easier solution);



    sorry i forgot to mention it, but I already have a static route on the internet router pointing it to when looking for

    If i do a trace from the internet router to, it hops to and then stops. For some reason it isn’t getting through the zeroshell box.


    Looks like either a routing issue (better double check that the routing tables are ok) or a firewall issue (check that the internet router doesn’t block traffic coming from, as well as accepts icmp).


    I think I figured it out. The GUI doesn’t seem to properly change the routing tables if you change the Default Gateway from one network interface to the other. For example, I created the zeroshell profile originally with Default Gateway Then, I added a second network card, and changed the Default Gateway to the new card (

    I solved the problem by just making a new profile and everything started working fine. However, if I run into this problem in the future, I’m guessing I could fix it by editing the routing tables from the Linux shell. Does anybody know a good website that talks about how to do that? Or just the commands so I can look up the man pages? Thanks.


    Are you sure you didn’t activate the Net Balancer. In that case the default gateway is controlled by this module and not by the static configuration.



    Ah, that would make sense. But, when I changed the Default Gateway, it looked like it automatically changed the Net Balancer Default Gateway setting. But I bet that was the problem. Maybe I had to go in and manually change it in the Net Balancer? Either way, thanks for all the help guys.

Viewing 7 posts - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.