Ralink usb wireless card

Forums Network Management Wireless Networks Ralink usb wireless card

  • This topic is empty.
Viewing 5 posts - 1 through 5 (of 5 total)
  • Author
  • #43697


    I’m new to Zeroshell and I was trying to get my SMC usb card (RT2870 chip) working with it. Zeroshell detect it but when it try to load the drivers I got the error FATAL: Module rt2800lib, rt2x00usbm rt2x00lib not found.

    After checking with find / -iname rt2* I can see such files (with .ko extension or not) in the disk.

    I have tested with the 2.0RC2 iso file and 2G image file and got same error.

    Can you please tell me where those files are supposed to be in order Zeroshell can load them?



    I forgot to mention that I have read this page
    so I have
    cp /root/kerbynet.cgi/scripts/start-wifi /DB/patch
    then added the line driver-load
    but I don’t know which script is the preboot one where I have to replace the start-wifi script by the modified one in /DB/patch

    Any help is welcome.



    I have found the preboot script.

    issue is with the sequence rt2800usb, rt2x00lib, rt2800lib
    start-wifi script get as MODULE this sequence rt2800usb, rt2x00lib, rt2800lib that make fail modprobe -r (modprobe is expecting only one module) then modprobe rt2800usb, rt2x00lib, rt2800lib fails for same reason. I have modified the MODULE variable to get sequence rt2800usb rt2x00lib rt2800lib and then modprobe -r now works. I got to replace modprobe by modprobe -a to get
    modprobe -a rt2800usb, rt2x00lib, rt2800lib working. Unfortunately it fails a bit later. As I’m not a unix expert I don’t understand anything to the script.

    I can’t go further 😥


    I have finally replaced the MODULE evaluation in the start-wifi script by MODULE=”rt2800usb” and I now it fails with the error rt2x00lib_request_firmware error – failed to request firmware
    I saw that on debian there are firmwares that should be located in folder /lib/firmware
    I found a deb file containing them for debian. Since this folder exists in Zeroshell I was thinking to extract the deb file here but zeroshell doesn’t have dpkg command installed.

    is there a way to extract the files into this deb file on Zeroshell? Which version of debian deb file should I take? There is one for each version of debian system but I have no idea on how to identify rt2x00 version

    Any help is welcome


    You were very close. I succeeded to run USB dongle based on RT5370.
    Neigher I had to deal with preboot script nor set MODULE.
    But I encountered the same error as you: “SIOCSIFFLAGS: No such file or directory”
    and finally from dmesg “rt2x00lib_request_firmware error – failed to request firmware”.
    Googling a little I find out on
    that it is enough to download rt2870.bin (the firmware for my chipset RT5370)
    and deploy it into /lib/firmware. I recommend to obtain the newest one via
    git clone http://git.kernel.org/pub/scm/linux/kernel/git/firmware/linux-firmware.git
    Firmware files are independent on Linux flavours.
    There is a small problem that ‘/lib/firmware’ is readonly but it can be easily workarounded:
    cp -a /lib/firmware /root
    mount -o bind /root/firmware /lib/firmware

    In my case ZeroShell is run under VirtualBox 4.3. And the USB dongle is very unstable.
    I am seldom able to connect do AP. But I succeded both on Linux (x64) and Windows 7 (x86) hosts.
    The first time I succeed only half an our so be patient.
    I have the same problem with stability for 3G USB modems. VirtualBox has problems with USB support.
    Also be carreful passing the password for WPA (under wifi-manger) because it is required to pass a password key (hex) instead of a password string.
    It can be simply obtained via wpa_suplificant.

Viewing 5 posts - 1 through 5 (of 5 total)
  • You must be logged in to reply to this topic.